PowerLine Internet not identified

Jan 5, 2019
2
0
10
Best answers
0
Hi,

I have a Fritz 510E Powerline set (It's a German company)

I was using it for around 3 months. My ethernet connection was working perfectly.

One day I loaded my pc and ethernet would not connect, the reason would be "unidentified network"

I have tried all of the steps I could find on the internet from netsh renew to manually changing IPv4 and resetting. It wouldn't work.

then I just kept on using wi-fi. Recently i remembered about having the powerline so i decided to give it another try and fix it.
I thought that the cable could've been the problem so I bought a new one, but it didn't fix. At the time I was using a extension socket, and somebody told me to allocate the adapter its prorer socket, that's what I did and at first it would work on and off. I would have connection for 5 - 10 minutes and then it would not work again, and then it started working just fine, I used it for about a week or slighlty more, and the same problem occurred. Now every time I load the pc, I have the "Unidentified Network" I have tried the same steps as last time, but it didn't help.

Hope to find some help here.

Thanks in advance.
 

adam.edward.palmer

Prominent
May 30, 2018
16
0
520
Best answers
4
The only advice I can give is just make sure that the adapter is plugged strait into the wall rather than with an extension lead. Other than that maybe try swapping the adapters around. I’ve used power line adapters for over a year now with both my pc and console and never really had any problems.

The only other think I can think of is that the product may be defective. It may be a bit of a stretch but try to get them exchanged.
 
Jan 5, 2019
2
0
10
Best answers
0
Thanks, I found the solution. One of the adapters was indeed faulty, apparently it got damaged(I guess when I was cleaning I hit it without realising) it works with other adapters. Thanks.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts