Question Pre-existing M.2 NVMe boot drive not booting after uninstalling and reinstalling in same system ?

Oct 23, 2021
So I built a new computer all the parts are new except the graphics card for obvious reasons, and the storage. I was using a WD Black SN750 SE to boot from on my pc. Started building the new one and put my M.2 SSD in the new system, turns out the mount for the cpu cooler on my new motherboard was missing so I had to wait a few days for it to come in. I moved the M.2 back to my original system to use while I waited and upon booting it up I got stuck in the “Automatic repair couldn’t repair your pc” loop with the error code of “logfile: E:\windows\system32\logfiles\srt\srttrail.txt.

Now what’s interesting is that my WD black M.2 is X:, not E: which is my Samsung evo sata ssd. I started digging and apparently it that may have been caused by me installing windows 10 back when I got the M.2 with the evo SSD and an old WD ssd connected at the same(this may also explain why I’ve had trouble updating windows for awhile, just crashes every time). It seems like part of the boot sequence relies on my EVO even though the M.2 was my boot drive. The M.2 stopped showing up in BIOS too.
I spent awhile trying to mess with command prompt to see if that would do it but nope, I tried every list of commands I could and none of them worked so I decided to just wait and see if it would work on my new computer. Nope, same issue.

I can’t even get to the windows repair screen without having the EVO connected aswell. I’ve been messing with BIOS settings for 14 hours today alone, trying to figure this out. I’ve tried doing a clean wipe through the repair screen aswell since I’m just desperate at this point and it gives me an error. I tried using a USB with windows 10 to make a new windows install and I can’t do that either, says they’re are no devices to put it on.

I’ve messed with the CSM settings a bit, secure boot, NVMe raid mode(still won’t show up, the other two sata ssds have no issue showing up in BIOS), tried booting without the two other ssds and only goes to BIOS. I mean I feel like I’m going insane. It was working perfectly fine right before I took it out of my old system and put it in the new one and never even started it up, when I put it back in that exact system 5 minutes later it’s just completely broken. Oh and the M.2 stopped showing up in my old BIOS as well, not just the new one. Please man I just want to play Destiny, like what is this ?

Relevant specs
Old Motherboard: MSI SLI Z97 SE Krait Edition
Old CPU: Intel i5 4690k
New Motherboard: Asus ROG Strix x570i itx
New CPU: Ryzen 5800x
M.2 NVMe SSD: WD Black sn750
SATA SSD: Samsung EVO 860
Last edited: