Question Prebuilt Allied Gaming Stinger Liquid Cooled Desktop PC- ethernet issues?

Oct 31, 2021
3
0
10
0
Hello,
I purchased a pre-built allied gaming stinger desktop PC here are it's components:
TUF Gaming B550-Plus mATX Motherboard
AMD Ryzen 7 5800X (4.7 Max Boost)
AMD RX 6700XT 12GB
120mm ARGB Liquid Cooler from Cool Master
16GB DDR4 3600MHz Gaming Memory with Heat Spreader from XPG
512GB PCI-E NVMe SSD from TeamGroup
Apevia 800 Watt 80+ Certified Power Supply
Came with a wifi USB adapter from allied gaming.

Issue I am having is that the onboard ethernet port does not work.
In Device manager I tried clicking on view-show hidden devices where I originally found the Realtek PCIe 2.5gE family controller was greyed out. Everything I looked up said to uninstall it so the computer would re-install on boot up. Several attempts to reboot and even install the driver from the realtek.com have not worked to restore the network controller(does not show up in device manager under anything or greyed out). Went into BIOS to make sure it was enabled. Read that it could be a mobo issue and to try purchasing a new ethernet port.

1 week later and my new ethernet port came, installed into PCIe1 slot (top one). still no network controller. also tried reinstalling the realtek driver but again it says it can not find the network controller and to "plug the cable".
New ethernet port:
2.5 GBase-T PCIe Network Adapter RTL8125B 2500/1000/100Mbps RJ45 LAN Controller Support PXE for Windows

Wifi adapter works great but would love better download speeds via ethernet.
ethernet cable is Cat8 in case that has anything at all to do with it.

Should I return this PC for faulty mobo?

Thanks in advance!
 

Lutfij

Titan
Moderator
Since you're able to get into BIOS, can you check and see what BIOS version you're on at the time of writing? Cross reference the BIOS version you're on and the version that's latest on Asus's support site, here. If you have a number of BIOS updates pending, gradually work your way to the latest, do not jump to the latest version. That prebuilt seems like a good build but the PSU's make and model doesn't inspire much confidence in the build. Keep on an ear and an eye out in case you see any other anomalies.
 
Oct 31, 2021
3
0
10
0
Bios is at version 2423. Still no network controlled showing up even under hidden devices in device manager.
I got into contact with the PC's manufacturer and they are helping me troubleshoot.
Recently tried CMOS. Only things I have not done that I can find on the internet is a reinstallation of windows or leaving out the RAM for half a day.

Any other suggestions to try?
 

ASK THE COMMUNITY

TRENDING THREADS