[SOLVED] Pretty bad performance on 3060 Ti

Jan 14, 2021
1
0
10
0
I am getting quite terrible performance in certain games, and below average performance in everything I've played so far. It is especially noticeable on GTA averaging low 50s when driving through the city. I went to YouTube and searched for benchmarks of my CPU/GPU combo and right enough my setup should be getting me well over 100 FPS with everything maxed on GTA.

Firstly, here is my setup:
  • - Ryzen 5 3600
  • - RTX 3060 Ti
  • - Corsair Vengeance LPX 2 x 8GB CL16
  • - MSI B450 Tomahawk Max
Things I have tried:
  • - Ensured I am on latest drivers
  • - Uninstalling drivers with DDU
  • - Fresh install of drivers
  • - Reseating the GPU
  • - Checked power settings
Here is a vid demonstrating my performance on GTA
 
Feb 11, 2021
1
0
10
1
I am getting quite terrible performance in certain games, and below average performance in everything I've played so far. It is especially noticeable on GTA averaging low 50s when driving through the city. I went to YouTube and searched for benchmarks of my CPU/GPU combo and right enough my setup should be getting me well over 100 FPS with everything maxed on GTA.

Firstly, here is my setup:
  • - Ryzen 5 3600
  • - RTX 3060 Ti
  • - Corsair Vengeance LPX 2 x 8GB CL16
  • - MSI B450 Tomahawk Max
Things I have tried:
  • - Ensured I am on latest drivers
  • - Uninstalling drivers with DDU
  • - Fresh install of drivers
  • - Reseating the GPU
  • - Checked power settings
Here is a vid demonstrating my performance on GTA
Have a very similar setup to yours and while I haven't tried GTA on my PC, the 3060ti's performance has been hit or miss for me.
One thing that's worth checking is your RAM speed. Bought some 3600mhz sticks but only found out later that they were being limited to 2133mhz. So check if they're installed in your mobo's recommended channels first, then check in your BIOS if XMP or DOCP is turned on. Maybe that can help you get some better performance
 

EridanusSV

Notable
Aug 16, 2020
347
44
940
68
Bro. It's GTA. I can't even change my damn resolution when I tried replaying the game this Christmas.

Some people with high-end PCs are also having issues setting up or just running the game in general. Not sure if there's a fix because I uninstalled the crap out of that game after it wont save my damn video settings.

Sorry for the angry rant
 
Feb 11, 2021
1
0
10
1
I am getting quite terrible performance in certain games, and below average performance in everything I've played so far. It is especially noticeable on GTA averaging low 50s when driving through the city. I went to YouTube and searched for benchmarks of my CPU/GPU combo and right enough my setup should be getting me well over 100 FPS with everything maxed on GTA.

Firstly, here is my setup:
  • - Ryzen 5 3600
  • - RTX 3060 Ti
  • - Corsair Vengeance LPX 2 x 8GB CL16
  • - MSI B450 Tomahawk Max
Things I have tried:
  • - Ensured I am on latest drivers
  • - Uninstalling drivers with DDU
  • - Fresh install of drivers
  • - Reseating the GPU
  • - Checked power settings
Here is a vid demonstrating my performance on GTA
Have a very similar setup to yours and while I haven't tried GTA on my PC, the 3060ti's performance has been hit or miss for me.
One thing that's worth checking is your RAM speed. Bought some 3600mhz sticks but only found out later that they were being limited to 2133mhz. So check if they're installed in your mobo's recommended channels first, then check in your BIOS if XMP or DOCP is turned on. Maybe that can help you get some better performance
 

ASK THE COMMUNITY

TRENDING THREADS