Pretty Urgent: After reassembling PC fans turn on once pc is plugged in. When I press power button, nothing happens.

dpepper509

Reputable
Jul 3, 2015
16
0
4,510
0
So UPS <mod edit> up my computer and my stock heatsink came detached. I just got a new one, put thermal paste on for the first time, plugged my graphics card in, everything is set. Then I plugged in my power supply and turned it to the on position. as soon as I did that, my fans started spinning. All of them. The CPU, 2 case fans, even my 2 graphics card fans on my GTX 970. Not normal. Nothing is supposed to do that until I turn the actual PC on. And when I tried doing that by pressing the PC power button, nothing more happens. The power indicator doesn't come on, the PC doesn't start up. This has been a huge ordeal and I'm sick of it. What is causing this now that everything is seemingly in place.

<Watch your language in these forums>
 

dpepper509

Reputable
Jul 3, 2015
16
0
4,510
0


Can you clarify what that is? Is that the one that gives power to the motherboard?
 

dpepper509

Reputable
Jul 3, 2015
16
0
4,510
0
Ok so I opened up the case, made sure every single wire was plugged in. Yeah that one by the CPU was too. I gave each one a little extra force. plugged cable back in and turned PSU on. No fans spinning! Then I pressed the power button and it booted!!!!! So happy. A couple questions that I had but don't want to make a new thread:

1. When I put my new heatsink, a cheap cooler master, it was my first time applying thermal paste myself. I'm not sure if I spread it right and everything, what's a good program to test temperatures under load? I forget what it's called but I hear it mentioned a lot.

2. When I do these tests, what temperature should my i5-4690 (non overclockable version) not exceed?

3.UPS mishandled this package but the only noticeable damage was the fact that the stock intel fan had come detached. What should I look for over these next few days to see if anything else is messed up?

4. This new Cooler master cooler uses the default intel pushpin system, no brackets behind the mobo. I think it's in there pretty secure but I couldn't get one of them to click, as it was already in the locked position somehow. If it fell while using my PC, would it mess a lot of stuff off? Also there's safety technology to shut my PC off if cpu temps got too high right? Just worried about this, as I did a really shitty thermal paste application.

Thank you everyone!
 

Similar threads


ASK THE COMMUNITY