[SOLVED] Previously had video display, but after turning the computer off, I no longer have display.

May 19, 2021
Corsair 465x case
Corsair 850 PSU
Asus ROG Strix B550 A MoBo
Ryzen 7 3700x
Corsair h100i AIO Cooler
Corsair Vengeance 3600 (2x16)
GTX 1070
Samsung 970 EVO 1tb
Also added one Corsair LL120 fan and the Corsair Commander Pro

This is a new build that I finished about a month ago and I’ve been able to use it the whole time. Everything is new besides my M.2 NVME, 2 HDD (500gb and 320gb I believe), and my GTX 1070 since I can’t find a gpu anywhere.

After originally powering on, I entered bios to make sure my boot drive was set to my M.2, which it was, and saved and exited. Booted fine the rest of the way.
Since then, I have not been able to get to bios for some reason. Anytime I would attempt to get to bios, my screen would pretty much do what it is now, just saying “No Signal, entering sleep mode” then black screen, then the same message repeatedly. Before though, I was able to just turn the pc off and back on and it would start up. Also, the only time I have seen anything on screen while booting was the first time I booted it. Every other time has just been black/ no signal and then my windows lock screen. And it would only take like 10 seconds. Motherboards green boot light comes on and gpu light is on.

I have checked my cables are all plugged in, tried separate hdmi plugs (hdmi works cause I tested it on my Xbox), this morning I tried my other pcie slot and plugged in a usb that I had windows on but forgot you need to get into bios to do that lol. I also tried plugging my hdmi into my motherboard even though I know I don’t have integrated graphics and it didn’t do anything.
when I get home I’m going to plug in the other pcie cord and see if anything’s wrong with any of that.
Any other suggestions?
Nov 11, 2021
clear your CMOS or update your BIOS by plugging in a USB drive with the BIOS file on it into the port with the black box around it with the text "BIOS" and press the "BIOS FLBK" button. you don't even need the CPU in the board really but it still works no matter what. if that still doesn't work then idk man your GPU is dead or your PSU is on its way out, maybe it's your ram. check it's inserted properly, reseat it and reseat your CPU if that doesn't work. if NOTHING that i've just recommended works, i don't know man.