[SOLVED] Previously working build gets to mobo logo and then no display [Solved]

Dec 19, 2022
Edit: Mysteriously this appears to have been an issue with starting my computer with an HDMI display. I know that's an issue for new computers before all the drivers have been installed but I didn't think this happened with a previously functional machine. Possibly it's actually the reformat that fixed this issue, and I just needed DP display to see it had been fixed, but there was no observable difference pre reformat and post reformat. Why this infrequently allowed a post mobo-logo-display even after reformat is also a mystery.

After removing and reinstalling some components (RAM, GPU) to get a GPU bracket and new fans in, the computer now gets to motherboard logo (and is capable of getting into the BIOS), but will stop sending any display and not appear to get into the OS after. It will irregularly allow me in if I manage to get into advanced recovery mode and then restart from there. If allowed in, everything functions just fine, but the problem resumes if it goes into sleep mode. BIOS can see all the components and reports on them accurately. Boot order only lists SSD card which contains the OS. All of the RGB on the RAM, GPU, and fans is functioning, if that matters.

My GPU fans will stop running once it stops displaying but I can't rightly recall if that's normal. Also, I only seem to be able to trigger advanced recovery mode if on the third boot I go into the BIOS and then exit the BIOS. F8 doesn't do it. There could be some user error for triggering advanced recovery mode though.

This build is a few weeks old and has been functioning well up until now.

Troubleshooting I've done:

Starting in advanced troubleshooting mode irregularly allows it to clear the motherboard logo and into the OS (it's worked only three or four times out of dozens of reboots). Rolling back updates did not resolve. Safe mode does not resolve. Finally reformatted disk, but problem persists. CMOS jump did not work.

I have tried reseating just about every component and cable except the CPU. I've tried testing each RAM slot and each RAM stick--one time, using just one stick in one slot worked, but I was not able to replicate. I have removed the new fans (and the GPU bracket didn't fit in the first place).
Last edited: