Question Previously working PC now showing motherboard VGA & Boot LED - no Post ?

Jun 14, 2022
1
0
10
0
Hey Guys,

I've had this premade from Newegg for a year now:
https://www.newegg.com/abs-ala238-gladiator/p/N82E16883360102R?Description=ABS Gladiator Gaming PC - Ryzen 9 5900X&cm_re=ABS_Gladiator Gaming PC - Ryzen 9 5900X--83-360-102R--Product&quicklink=true&RandomID=9899217241204520220614175833

CPU: AMD Ryzen 7 5900X CPU
Motherboard: Asus TUF Gaming X570 Plus Wifi
Ram: CORSAIR Vengeance RGB 32GB DDR4 3600MHz
SSD/HDD:1TB Intel 670P M.2 NVMe SSD
GPU: EVGA GeForce RTX 3080 FTW3
AMD HD6970
PSU: EVGA 850W 80 Plus Gold

It has been working essentially flawlessly (Except when my 3080 died in the fall and had to be RMAed) since I bought it a year ago.

Recently I've had a lot of random misc crashes and blue screens. At one point i thought it was my RAM, but I ran a Memtest86 and had no errors.

Today it wouldn't post and DRAM light was on. I started removing DRAM units to see if it would change. After the third DRAM removal the lights changed from DRAM light to VGA + Boot.

Things i tried:
  1. I switched out my GPU to another computer (works). Switched GPU from other computer (MSI 3070) to this computer. Doesn't work
  2. Switched slots of GPU from top to bottom slot
  3. Tried booting without GPU
  4. Clearing CMOS
I guess the only things I haven't tried are the PSU/CPU/SSD and Mobo itself. I have a spare PSU laying around but I doubt its the problem. I don't have a spare CPU.

Was thinking of bringing it into Microcenter for a diagnostic.

Any ideas?

Thanks
 

ASK THE COMMUNITY