• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Prime X470 Motherboard won't boot

Nov 17, 2019
4
0
10
0
I've just bought & put together a Prime X470 motherboard along with a Ryzen 5 CPU & 32GB of Corsair Vengeance RAM (2 x 16GB) Also a new 800 watt ATX PSU.

It won't boot, nothing comes up on my monitor, I've tried using the HDMI directly on the mobo & have also tried a graphics card. I've switched around the RAM, cleared the Cmos. The board doesn't come with onboard speaker so I've just ordered one so I can tell if the board is beeping any errors but in the meantime are there any suggestions. Everything comes to life when turned on, hard drive whirrs, fans go etc just no screen display.

I bought the mobo new this week & am unsure as to whether or not it has the correct bios, maybe this is my issue? Am I able to update the bios by putting it onto a USB stick & plugging in?

Appreciate any help.
 
Nov 17, 2019
4
0
10
0
Hi
Looking at the box it says,
AMD Ryzen 5. 3rd Gen processor - PCIe Gen 4 Ready.
And on the back
Zen 2 Architecture AMD Socket Am 4
 
Nov 17, 2019
4
0
10
0
Whilst I'm at it can I also ask. When I plug in the 4pin ATX power connector the CPU fan rotates at a slower speed than if I have no 4pin ATX plugged in.
Seems strange to me that?
 

kanewolf

Titan
Moderator
The mobo box doesn't actually have anything that indicates whether or not it is 3rd generation compatible. I have checked the Asus site & it does state all good with the Ryzen 5 3.6. https://www.asus.com/us/Motherboards/PRIME-X470-PRO/HelpDesk_CPU/
The only bios mention on the box is that it's UEFI Bios?

Is it possible the motherboard has shipped with an old BIOS that I can't update as have no screen.
Yes, that is a risk with a X470 and a 3xxx CPU.
 

ASK THE COMMUNITY

TRENDING THREADS