Question Prime X570 Pro, I Might Have Screwed Up Picking This Motherboard

Haven't been active here in a long time.

Well it's been a long time since I built AMD, and the first time I've built an AMD system for myself. The Prime X570 Pro seemed to tick all the boxes that I wanted, though it was a bit more than I wanted to spend. Initially I was going with a TUF GAMING X570-PLUS, but the place I was purchasing from was out.

So I get this motherboard but the memory kit I wanted was the HyperX Fury RGB 16GB DDR4 3200MHz CL16 Dual Channel Kit was out of stock too. The sales person suggested Trident Z RGB Series 16GB DDR4 3200MHz Dual Channel Kit and I agreed as I've had pretty good luck with GSkill in the past. The CAS settings are not extreme on this kit either at only 16.

So I get it home and assemble it, and it POSTs the very first time. I don't know if I'm just lucky, or that good, but I've never had a system not POST. I switch on the DOCP (AMDs equivalent to XMP) and it POSTs, but occasionally it hangs during POST. Everything is stable when I'm in the BIOS, so I proceed with updating the BIOS as the version on the board is quite old. So the latest is 1405, I forget what was on it originally. After updating successfully, I try to enable DOCP again, no POST and refuses to POST on subsequent attempts. It's so bad it doesn't recover on it's own, I have to short the clear CMOS pins. So rather than fight with it I leave it at 2133, and start installing Windows and setting my system up with the intent of re-visiting the RAM speed later.

So my system is at this point running stably, all drivers installed. Having some issues with Armoury Crate and syncing the fans in my case (View 37 ARGB) with Aura Sync, but not a deal breaker. So having time I try everything to get my RAM up to it's rated speed with no luck. I even tried using Ryzen DRAM Calculator (V1.62) with no luck. So I start Googling the issue and it seems like I'm not alone. It looks like a BIOS setting that is present on other X570 motherboards from ASUS and others is DRAM Vboot Voltage isn't present on this motherboard. Apparently this voltage overrides the default voltage (1.2V specified by JEDEC) for training the memory during POST. Having come from Intel, I'm pretty sure this isn't a thing on that platform. I can only assume motherboards built around Intel CPUs use the DRAM Voltage setting in the BIOS during the initial training phase of the POST. Whereas with this platform if you don't override the voltage using DRAM Vboot Voltage (or in my case you don't have it), then you run the risk of the motherboard failing to POST during the memory training phase

I have almost exclusively used ASUS for well over 10 years after having repeated issues with GigaByte. GigaByte's customer service was pretty good, but it's always better if you don't need it. I've always heard ASUS support sucks, but I've been lucky enough to not need to engage them until now. So I hit up the Chat option on their support site. Turns out they won't even discuss the issue if the kit you have doesn't appear on their QVL, even though the same series of RAM appears on it in a 32GB kit. More to the point I just wanted to ask if this BIOS setting would be added at some point in the future, but I didn't make any headroom there.

So I reluctantly start discussing the ARGB issue I was having. The case I mentioned above has an ARGB controller built in, but you can connect the ARGB header on the motherboard to the controller with a cable provided by ThermalTake. If you hold the LED mode button in for 3 seconds or greater, it switches from case controlled to motherboard controlled or vica versa depending on which mode it's in when you press it. When I switch it to motherboard control, only the rear fan responds (case has 3 fans total, 2 in the front and one in the back) and only partially. Only about the top 1/3 of the LEDs respond, but it does respond correctly. Comes up with the right color and effect. I noticed this right away since I started setting this feature up right after installing all the drivers and before any other software was installed. This wasn't really a conscious thing, just happens that as soon as it booted to Windows, it prompted me to download Armoury Crate. So after downloading it I tried to set it up and discovered this odd behavior. I'm not sure that it's related to Armoury Crate, or something to do with ThermalTake's controller. He asked about my troubleshooting and we went over that I'd tried uninstalling / re-installing (twice actually). I casually mentioned I noticed something else later on where after installing MSI Afterburner which I normally have start with Windows, Armoury Crate / ASUS Aura stopped seeing the RGB function of my Strix 2060 Super. I troubleshot this on my own and discovered that I had to stop Afterburner from starting before Sync started working. The ASUS support person says to me that I shouldn't have any other software installed on my system with Armoury Crate. Initially I take this to mean as running when Armoury Crate is running, but I verify by asking, and he repeats installed. So I said "So Windows and that's it?" and he says correct. So I'm thinking "Wow", if I want to use Armoury Crate to synchronize the RGB effects on my system, that's all it can do. How many of you here build a couple grand system so all that it does is RGB? I was never really that keen on RGB to begin with, but I thought it might be fun to give it a shot. Paint me with a bit of regret. Needless to say I took a screenshot of the chat window as I couldn't believe was I was being told.

I had to convince him the issue with the case fans pre-existed before any other software had been installed on the system. So I was given a motherboard feedback form for the RGB issue.

I have always loved ASUS hardware but never trusted their software. I've seen Ai Suite (pretty much every version I've tested) create all sorts of system instability. Third party monitoring software always does a better job of this and I've been OK with it. I don't know why I expected anything different from Armoury Crate / Aura Sync. I wonder if there is a programmer out there that will provide a third party RGB software as an alternative to ASUS / MSI / GigaByte / AsRock software? Something like UnWinder did for graphics cards with Afterburner.

Sorry if this is a bit of a rant interspersed with my issues. Anyone else seeing the DOCP / XMP / Custom RAM setting issue that I'm seeing with this board? And yes this RAM kit works at the rated speed on a comparable Intel system at it's XMP setting. Unfortunately I don't have another AM4 system to test it in.

Edit:

Forgot to show system specs
Ryzen 7 3700X
Prime X570 Pro
Trident Z RGB 3200 CL 16 2X8GB
Strix 2060 Super OC
Samsung 970 EVO Plus 550GB
WD 4TB Blue
EVGA SuperNova 1000W G2
Fractal Design Celcius S36
ThermalTake View 37 ARGB
 
Have you tried configuring the ram manually? You don't need Ryzen mem calc to do it. Just change the 5 timings printed on the DIMMS, and enter the voltage at 1.35. You will leave all other ram options on default except the ones in the XMP profile. You can get the timings you need to change from CPU-z, if there is no sticker on the DIMMS
 

ASK THE COMMUNITY

TRENDING THREADS