Question Probably Broke the BIOS of my MSI Mobo 🤦‍♂️ My first thread after trying like everything

Sep 17, 2020
1
0
10
0
Hello Dear Community,

In the past I’ll often floated back to this forum. The solutions you gave other users with similar problems i was looking to solve helped me in many cases. Now i have created an account to submit my first own Case and I’m really hoping someone can help me just as good.

Short Version: Computer doesn’t start after probably breaking the BIOS on a Mainboard by selecting a BIOS file to boot from in the UEFI Settings. The Screen stays black when powering on. Are there any known solutions? Can a hardware flash help me?

Longer Story how it got there:
Stupidity overcame me and i broke the BIOS/UEFI of my Mainboard. The specific Model of the Mainboard is: MSI B75MA-P45. The Mainboard had a Splashscreen Logo of the Company it was used by. From what i learned this is a branded BIOS? Also the BIOS-Version installed was super old. What i wanted to do is to update the BIOS with the newest Version for this specific Mainboard provided on the MSI site. I also hoped that this will remove the Branding. I already had some experience with flashing BIOSes in different kind of ways, so i thought it won’t be a big deal. I was Trying to flash it from the UEFI Flash Option with the BIOS files on an fat32 USB Stick and to flash it from bootable DOS. Unfortunately both didn’t work.

In the UEFI there is one more option called “Select one file to boot”. Here is the description for that option: “When the BIOS Boot function as sets to [Enabled], this item is selectable. This item allows to select particular BIOS file from the USB/ Storage (FAT/ 32 format only) drive. And the system will boot from selected BIOS file. “
I selected the BIOS file from the USB Stick and got the Warning that the System probably won’t restart selecting this option. Left it at this thinking I’ll come back in a moment to this and continued to browse the UEFI to get familiar with the rest of the settings. I left for a minute to get something to drink and when i came back i restarted the System. The moment it didn’t boot i realized i left file boot option active and facepalmed myself.

I tried all kinds of BIOS reset methods that i know of. I also left it completely disassembled for a week and tried it again. But nothing. When powering on just a black screen. The only solution i can think of that would probably help is to do a hardware BIOS flash. I already ordered the tool for it but i would like to know if maybe anyone of you here has a suggestion for what else i can do?
It would be fine for me now to use the old branded bios, it was working okay and i would just deactivate the full screen boot logo.
 
Last edited:

ASK THE COMMUNITY