• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Problem with Broadcom wireless network adapter

Status
Not open for further replies.

Ducki

Reputable
Feb 19, 2014
3
0
4,510
0
Hi,

I recently built a computer and have just run into the first issue that has me stumped.
My issue is in connecting to any wireless network.
The onboard wireless adapter is shown in device manager and ipconfig/all. It has no problem in finding wireless networks but just wont connect to any.
I have installed the latest drivers for my adapter and have tried to connect to various different networks including my router, hoc (laptop) and hotspot (phone) with no success.

Any help would be greatly appreciated!
Thank you.

Motherboard - AsRock Extreme9/ac
Wifi - Broadcom 802.11ac
Os - Windows 7
Router - Netgear DGN2200
 

Ducki

Reputable
Feb 19, 2014
3
0
4,510
0


Yes, both IPv4 and IPv6 are set to obtain ip address automatically
 
have you tried connecting to a network with no security featuers at all?
what actually happens when you try to connect to a network, does it even try(like saying connecting to network or anything?)
have you run windows 7 network troubleshooter?(right click on wifi down in the taskbar then select troubleshooter or go to windows help and type network troubleshooter, sometime this will help so config issue)
 

Ducki

Reputable
Feb 19, 2014
3
0
4,510
0


Yeah I have tried all of that. The strange thing is that the wifi adapter seems to be communicating with the router (when I try to connect I get past the stage of putting in the router password) after which I just get a very basic 'unable to connect' msg.
The troubleshooter always ends with 'problem with wireless adapter or access point'.
I fear that the Broadcom adapter itself is defective.
Thanks for the reply though. :)
 
Status
Not open for further replies.

Similar threads