Question Problem with Corsair k100 mechanical keyboard

Jun 1, 2022
2
0
10
0
Hello,
bought Corsair K100 keyboard yesterday. The problem is that it does not turn on when powering on PC, does not light up, can't get into bios I unless hook up another keyboard. Only unplugging its usb cable and plugging back in helps. Same thing happen after reboot.

The PC is still pretty new, mainboard is ROG STRIX B550-F GAMING Wi-Fi.

Before restarting or powering on I tried several things:
Tried unplugging every other device from usb's
Tried connecting keyboard to all possible usb ports
Updated motherboard's BIOS, even tried Beta version (which is released pretty recently - in 2022 April)
Updated keyboard firmware several times
Tried resetting keyboard holding ESC (Corsair method for reset)
Tried resetting PC BIOS
Tried various BIOS settings, like legacy usb off and everything USB related. Disabled fast boot, etc.
Tried connecting k100 keyboard to my laptop, it powers-on and works fine, but before blaming PC, I also tried different keyboards on that PC, all of them working fine.

Any suggestion what can I try next? I thought maybe try downgrade keyboards firmware, now it's v.0.32.262, but was not able to find older firmwares for download. Also tried searching internet, havent found solution, most issues are resolved by resetting keyboard holding ESC when plugging in, but not in my case.

Thanks in advance
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Just to corroborate your thread, are you on the latest BIOS version? If so, could you parse a BIOS version number? is it possible to state what the BIOS version was prior to updating? How did you update the firmware for the keyboard?
 
Jun 1, 2022
2
0
10
0
Thanks for quick reply, I updated Keyboard firmware using iCUE tool made by Corsair. It allows to update firmware to the latest from internet automatically or select update file manually.

Regarding ROG STRIX motherboard, It has been 2403 before. And I tried 2604 (most recent stable), and 2803 (most recent Beta).

In my opinion most likely it is compatibility issue, probably Motherboard to blame, I guess since there is no discussion with similar problem on internet, might be possible that other people does not happen to have both items, or solving issue somehow by themselves.
 

ASK THE COMMUNITY