[SOLVED] Problem with drivers

Mariusglock

Prominent
Jun 13, 2020
126
22
615
8
Hey forum
I have a RTX 3060 TI, and i do have Geforce experience app installed. The app tells me that new drivers (ver. 511.23) are available. Im currently at (ver. 497.29).
Fine I downloaded the drivers throu the app, and after download installed them, screen went black then came back on again( usual driver installation proccess).
After the install, Geforce experience app shows that I still have the old 497.29 driver isntalled, despite that i just updated the drivers to 511.23.
I checked device manager, in display adapter -> options -> driver info, it also shows older date of the driver.

Can this be problem with geforce experience app? Have you guys encountered issues with this app from Nvidia?
 
Last edited:

Tac 25

Upstanding
Jul 25, 2021
383
59
290
5
I have been using the app for more than a year. Because I use it to record videos when playing co=op with my friend in Genshin Impact.

anyway, you can try downloading the entire driver again with Geforce Experience.

or you could just get it from Nvidia's site. When you get it, do a clean installation.

 

Tac 25

Upstanding
Jul 25, 2021
383
59
290
5
I have been using the app for more than a year. Because I use it to record videos when playing co=op with my friend in Genshin Impact.

anyway, you can try downloading the entire driver again with Geforce Experience.

or you could just get it from Nvidia's site. When you get it, do a clean installation.

 

ASK THE COMMUNITY