Question Problem with Gainward RTX 2070

Jun 23, 2019
3
0
10
0
Hello everyone. I'm having problem with my RTX 2070 graphics card. It all started with a crash and system reboot while running a 3d application (a game). Now i get these weird artifacts (if that is what they are called) - more precisely green lines and dots while running windows. I've tried uninstalling the driver using DDU and installing the newest from Nvidia website but it doesn't seem to work. MSI Afterburner can't recognize the driver even though it is installed. So I assumed it was not a software problem, but a hardware problem. I've replaced the video card with my old GTX 970 and everything works fine. My conclusion is there is something wrong with my video card. Do you guys have any suggestions or opinions that might help? Bought the card in November so the warranty is valid. From your experience, is it dead or can it be repaired somehow? Any answer is appreciated. Thanks in advance. Links for pictures below.

1 2 3 4 5
 
Jun 23, 2019
3
0
10
0
Hello and thanks for taking the time. The power supply is a Seasonic S12II-620 Bronze (620W). Forgot to mention I haven't messed with anything, everything is stock. Specs below:
  • AMD Ryzen 7 1700
  • ASRock X370 Pro4
  • Corsair Vengeance 16 GB DDR 4 3000
  • Samsung SSD 860 EVO 500 GB
 
Jun 23, 2019
3
0
10
0
Unfortunately I do not have a spare PC that I can use to test it. Anyway I sent it in. Hopefully I'll get an answer soon. When I know what the problem is I'll post it here. Maybe someone will find it helpful.
 

ASK THE COMMUNITY

TRENDING THREADS