• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Problem with keyboard and mouse work in bios but shutoff at windows loading after changing Ram

Jun 23, 2020
1
0
10
0
Hi, I wasn't sure of this was the proper section for my question as it's keyboard/mouse problem but it happened because I changed my RAM.

My setup is this:

Mobo: Asus rog maximus hero iX wifi
Cpu: intel i7 8700k
Cooler: noctua dh15
Gpu: nvidia gtx 1080 gigabyte windforce OC 8g
Ssd: samsung 960 pro nvme m.2
Case: rosewill Nighthawk 117
Benq 27" monitor through displayport
Asus 24" monitor though HDMI
Keyboard and mouse are through usb cable.

My ram was corsair ddr4 3000mhz and i changed it for teams t-force 4133mhz as i will be using the corsair 3000mhz as an upgrade in my second pc. My cable management was very poor and access to the ram with the noctua and all those cables was restricted. This new ram isnt exactly small either so I unplugued everything and redo my cables and put the new ram. When I launched my pc afterward it failed to post. I had to drop the ram to 4100 instead of 4133.

After that it launched windows but my keyboard and mouse shut off as soon as windows is loading. They worked fine in the bios. I tried setting XMP off then i tried to just load optimized defaults. Nothing changed. I tried putting back the old ram and the problem remains. I tried all usb ports and it doesn't fix anything. I'm scratching my head on this one.

The ram works, the mobo works, the keyboard and mouse works, windows load fine and no settings were changed in the process before trying the optimzed defaults. I even tried unpluging and emptying the battery by holding the power button so that there is no residual charge. I've tried another keyboard and mouse but same result.

Anyone have an idea what's going on?

Thanks in advance.

Edit: verified my phone charges in every usb port so they work. And I tried to clear cmos. Still a deadend.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS