Question Problem with MSI’s built in WiFi

Jun 23, 2019
104
2
85
0
Okay so I have the MSI MPG X570 Gaming Pro Carbon WiFi. I recently installed all of the motherboard drivers and set up WiFi with the provided antenna. The WiFi seems to work well, when it’s actually connected anyway. There are times where it’ll randomly disconnect, which isn’t a huge deal for me right now since I’m mostly playing single player games, but this could be a huge issue in online games. I’ve never had this issue with my old WiFi USB, which I’ve heard has the least powerful signal, which is why I’m confused. My room is on the top floor of my house, and I have the antenna on the top of my case. But one thing I will say is that my router is on the lower floor of my house, in a room that’s relatively far away from my room. But I don’t have issues with any of my other connections, so I’m not sure if it’s a router issue. Does anyone know what the problem could possibly be?
 

Ralston18

Titan
Moderator
Random disconnects:

Loose connection - check the connections to ensure that all are fully and firmly connected.

Defective antenna cable - try swapping in a known working wifi antenna cable if at all possible.

Physical interference - try relocating the antenna by directly moving it around and by using an antenna extension cable . Does not take much to interrupt wireless communications especially in some threshold situation. Meaning that the connectivity is right at some "line" that makes the signal come and go.

Duplicate IP address - Determine if some other network device is using the same IP address. Likely a static IP.

Failing the above, try changing frequency and channels. Especially if your house is in an area likely to have other surrounding wireless networks.
 

ASK THE COMMUNITY