Question Problem with my RX 580 (at least i think it is a GPU problem) ?

Jun 21, 2021
5
0
10
0
Hello, its my first thread here and im not really the smartest one with computers, so i will try my best to explain my issue and i hope i can get some help from you folks.
If any more information is needed , that i havent provided now, feel free to ask for it in comments, i will be actively checking this thread and providing any assitance needed.

MY PC SPECIFICATIONS.

CPU - AMD Ryzen 3 2200G Link to CPU in PassMark
GPU - Saphire Nitro+ RX580 (4GB version) Userbenchmark link to GPU
RAM - 12GB of DDR4 ram (not exactly the best firm, if its important i can add some pictures later on)
Mobo - Asus Prime A320M-K
Monitor - HP w1907v Link to screen (Using HDMI to VGA converter to plug it in gpu)
PSU - Energon EPS-650W Link to PSU
OS - Windows 10 Pro.
Screenshot from GPU-Z (if it helps) - here
The problem i've been experiencing started very recently. When im playing games my monitor just suddenly shows Monitor is going to sleep, and goes black. I have to use powerbutton, to restart my pc and usually my GPU drivers are like gone (when i click the drivers setup, it just offers to repair them.) The problem can trigger at random times, its not like after playing 5 or 10 minutes, it can happen after 5 minutes of playing or over 30 min +


The 2nd problem is my GPU's Bios switch option. Only read some stuff about it today, and realised that all this time my GPU was running on quiet instead of performance mode, after turning off my computer and flipping the bios switch, i ran into some weird issue. Computer boots up as usual, but as soon as my driver software gets auto run on startup my screen goes black/green.

Stuff i already have tried:

  • Reinstalling my GPU drivers using DDU (thru safe mode)
  • Reinstalling my entire OS (did that less then a week ago.)
  • I dont know if it did anything, but i also ran some stresstests in Aida64 and Furmark (both ran without any problems.)
Really looking forward to any help/assistance u guys can provide me.
Thank you.​
 
Jun 21, 2021
5
0
10
0
Can't rule out the PSU being responsible for at least some of your problems --- it's a piece of junk -- very bad choice, especially for a gaming rig.
Yes, i was actually thinking about the same thing. A friend of mine said a modular psu would be nice, but im currently not doing exactly great in finances.

Yesterday i checked some not to expensive ones, what do you think about this one? - https://www.1a.lv/p/thermaltake-litepower-550w-ps-ltp-0550npcneu-2/uy4?mtd=search&pos=regular&src=searchnode

Its 80 plus bronze, i think its a decent choice for that type of money

It should have the pins i need aswell, because currently i need to use molex to 6pin coverter, so i can use my GPU (gpu needs 6+8pin.)

I can provide a picture with how it currently looks, if its needed
 
Last edited:
Jun 21, 2021
5
0
10
0
That's another bad choice according to this thread

You need to be looking at Corsair, Seasonic or EVGA ones.
Okay, ima check out some of the brands u specified, and send u some examples u can tell me if they good or not. Im even down to pay some more , because thats the type of thing thats going to last me a long time.

Corsair - https://www.1a.lv/p/corsair-cv-series-psu-550w/7xay?mtd=search&pos=regular&src=searchnode

EVGA (these ones are a little bit more pricy) - https://www.1a.lv/p/evga-500bq-500w/8x8s?mtd=search&pos=regular&src=searchnode (this is a modular one aswell. 500W should be enough right? )

And from Seasonic - https://www.1a.lv/p/seasonic-core-gc-series-psu-500w/797m?mtd=search&pos=regular&src=searchnode

From these 3 im kinda leaning towards the EVGA modular one , but what do u think?
 
Jun 21, 2021
5
0
10
0
I think 500w would be cutting it too close for an RX 580 (it's known to have voltage spikes) so for a safety margin I'd go with the Corsair CV550.
And if i throw in those extra 10€ and get the EVGA Modular one with 600watts?

By the way extra side note - for some reason when i plug an ultra old screen of mine i found in the attic (Samsung Syncmaster 510n) everything works, no sleeping monitors, i can play my games.
 

Phillip Corcoran

Titan
Moderator
"And if i throw in those extra 10€ and get the EVGA Modular one with 600watts? "

Even better.

"By the way extra side note - for some reason when i plug an ultra old screen of mine i found in the attic (Samsung Syncmaster 510n) everything works, no sleeping monitors, i can play my games"

Beats me.
 

dorsai

Distinguished
I'd flip the BIOS switch back to quiet mode until you replace the PSU.

I would go with a Gold rated 500w supply over a Bronze 600w supply since your system isn't pulling a lot of power. Bronze rated supplies in general are made with the least reliable components and offer minimal warranties.
 

--SID--

Prominent
Jan 23, 2021
676
157
590
12

ASK THE COMMUNITY

TRENDING THREADS