[SOLVED] Problem with .NET Framework 4.5 ?

Jan 28, 2021
8
0
10
0
Hello!

When I try to apply buildDebugAndMac.bat (it's needed for a setup to work) I get the following error:

C:\Program Files\dotnet\sdk\3.1.407\Microsoft.Common.CurrentVersion.targets(1177,5): error MSB3644: The reference assemblies for .NETFramework,Version=v4.5 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

View: https://imgur.com/a/1ChoTmd


I tried installing net framework 4.5 from the link that I got from the error but It tells me:

1. Microsoft .NET Framework 4.5 is already a part of this operating system. You do not need to install the .NET Framework 4.5 redistributable.

2. Same or higher version of .NET Framework 4.5 has already been installed on this computer.

View: https://imgur.com/a/lIF0RoU


What I can do for the .bat file to work?
 
Last edited by a moderator:
Jan 28, 2021
8
0
10
0
Google .net 4.5 developer pack download. Only download this from Microsoft nobody else

http://www.microsoft.com/en-us/download/details.aspx?id=42637

And I have no idea what you are even trying to do and what that batch file even does
The batch file solves an error that I am getting if I'm trying to install a setup from github.

When I google .net 4.5 developer pack download I am only getting 4.5.2 developer pack and it don't work, do I have to restart my pc in order for it to work?
 
I have no idea what product you are trying to get to work. Try rebooting but I have no idea what you were doing or what you are attempting to do or what software are you are doing it with as you have provided no details whatsoever
 
Download the developer pack for.net 4.8 and that should work

Windows 10 comes with 4.8 and that means you cannot install an earlier version of 4.x .net so you must install the developer pack for the latest one that’s installed on your box
 
Jan 28, 2021
8
0
10
0
Download the developer pack for.net 4.8 and that should work

Windows 10 comes with 4.8 and that means you cannot install an earlier version of 4.x .net so you must install the developer pack for the latest one that’s installed on your box
I installed it and it doesn't work, you can see in that video what I'm trying to do

View: https://youtu.be/CorLwZBqBM8?t=372
its at 6:12, there are English subtitles
 

ASK THE COMMUNITY

Latest posts