Question Problem with new i7-12700K - DDR5 build ?

Jul 4, 2022
3
0
10
0
Asus rog strix b660-g wifi
i7-12700K
Crucial RAM CT2K32G48C40U5 64GB Kit (2x32GB) DDR5 4800MHz CL40

I can't boot BIOS, no hdmi signal at all. Display is checked with another computer.
Then I made a minimal build with only mobo, processor and one piece of RAM
Same result. Power is ok, all the LEDs are flashing, but no hdmi signal.

Then cleared CMOS with CLRTC Pin and tried it. Then I updated bios to the latest stable version. Result is the same.

What else I can do here? I know there is similar topic (https://forums.tomshardware.com/threads/problem-with-new-i7-12700k-build-please-help.3755795/?view=date), but I have different motherboard and RAM.
 
Asus rog strix b660-g wifi + i7-12700K + Crucial RAM CT2K32G48C40U5 64GB Kit (2x32GB) DDR5 4800MHz CL40

I can't boot BIOS, no hdmi signal at all. Display is checked with another computer.
Then I made a minimal build with only mobo, processor and one piece of RAM
Same result. Power is ok, all the LEDs are flashing, but no hdmi signal.

Then cleared CMOS with CLRTC Pin and tried it. Then I updated bios to the latest stable version. Result is the same.

What else I can do here? I know there is similar topic (https://forums.tomshardware.com/threads/problem-with-new-i7-12700k-build-please-help.3755795/?view=date), but I have different motherboard and RAM.
Try display port.
 
Jun 24, 2022
16
0
10
0
May not be related yet my Asus ROG Strix Z690-A Gaming WIFI D4 won't wake my monitor yet same video card, dp cable and monitor on my old X99-s motherboard does !?. Misleadingly appears as if there is no video. I have to switch on my PC IMMEDIATELY after mains so the motherboard boots before the monitor goes to sleep !. PC still boots otherwise and Windows wakes the monitor yet motherboard white (video) led stays on if I'm not quick enough at boot time...
 
Jul 4, 2022
3
0
10
0
May not be related yet my Asus ROG Strix Z690-A Gaming WIFI D4 won't wake my monitor yet same video card, dp cable and monitor on my old X99-s motherboard does !?. Misleadingly appears as if there is no video. I have to switch on my PC IMMEDIATELY after mains so the motherboard boots before the monitor goes to sleep !. PC still boots otherwise and Windows wakes the monitor yet motherboard white (video) led stays on if I'm not quick enough at boot time...
Does it mean that you plug your monitor to X99 PC and quickly re-plug it to Z690 PC during Z690 PC POST? I tried to switch on and off my display during startup and it was "no HDMI sygnal" every launch, 10 seconds and then it goes to power saving mode...
 
Jun 24, 2022
16
0
10
0
Does it mean that you plug your monitor to X99 PC and quickly re-plug it to Z690 PC during Z690 PC POST? I tried to switch on and off my display during startup and it was "no HDMI sygnal" every launch, 10 seconds and then it goes to power saving mode...
No... I have no issue at all with the x99-s. Yet with the z690 board I have to switch on the PC immediately after switching on the mains to ensure the board wakes before the monitor goes to sleep ,(I only have 3 seconds or so). If I miss it for some reason I quickly use the monitor power button to switch it off and on again but sometimes too late. Moving live video cables is never a good idea, I know of many laptop video outputs blown by folk doing that while switched on.
 
Jul 4, 2022
3
0
10
0
No... I have no issue at all with the x99-s. Yet with the z690 board I have to switch on the PC immediately after switching on the mains to ensure the board wakes before the monitor goes to sleep ,(I only have 3 seconds or so). If I miss it for some reason I quickly use the monitor power button to switch it off and on again but sometimes too late. Moving live video cables is never a good idea, I know of many laptop video outputs blown by folk doing that while switched on.
That makes sense, I had the same issue but still with "scanning HDMI -> no HDMI signal" result
 

KyaraM

Notable
Mar 11, 2022
788
275
890
30
Sometimes, one port, eg. HDMI, isn't working while another, eg. DP, does. For example, my monitor won't find the GPU if connected to one of its DPs, but has no problem with the others or the HDMI port. Personally, I would to see if another port works. Another culprit could be the cable itself.also, you said display was checked with another computer. Did you check the other display on the computer in question, too? Might be worth a try if possible.
 

ASK THE COMMUNITY

TRENDING THREADS