Question Problem with Primary Graphics PCI-E on 760GMA-P34 (FX)

Oct 29, 2019
1
0
10
0
Hello all. This might belong in the GPU section as well, but I feel like the problem is with the motherboard.

I have a MSI 760GMA-P34 (FX) mobo, running an AMD FX-6300 processor, along with 16GB of DDR3 RAM, and a SSD hard drive connected to SATA 6.0Gb/s.
I have just upgraded my graphics card to a Radeon RX 5700 8G (from a Radeon R9 360).

I am trying to disable the integrated graphics on the motherboard, and have the system use only the PCI-E GPU.

The problem I am having is when I select "PCI-E" as my Primary Graphics in the BIOS (AMI P.1), the system fails to boot into Windows. The BIOS posts on the new GPU, SATA is recognized, but then immediately after posting, the GPU displays a black screen, no mouse, no windows logo, everything is locked up. The monitor does not lose signal.

When I change the BIOS back to Internal Primary Graphics, everything works perfectly. Windows 10 boots, the 5700 GPU is smooth, no issues whatsoever.

I have reset the CMOS, re-seated and reinstalled the new GPU twice (with proper Safe-Mode DDU steps, etc.), pulled RAM, and have tried disabling the Onboard Graphics from Windows Device Manager (ATI Radeon 3000). I have also tried swapping video outputs from the back of the new GPU to the monitor during it's lockup.

Does anyone here know a solution to this?
For budget and time reasons, I need to keep this motherboard, and I am very close to calling a local professional to help me with this.
 

Phaaze88

Admirable
Herald
From what I can see from the online user manual and product page, your current motherboard runs a Legacy Only bios.
Newer graphics cards, starting from Nvidia's GTX 900-series and AMD's RX 400-series, require a UEFI bios.
If you are unable to upgrade from your current platform, you are stuck with the R9 360 - assuming you haven't gotten rid of it already.
 

ASK THE COMMUNITY

TRENDING THREADS