Question Problem with setting up new samsung 970 plus - cant get into bios

Feb 15, 2020
1
0
10
0
Yesterday i bought a Samsung 970 Plus SSD. I went and tried to boot up into bios so i could set it up. But since i have fastboot on it boots too fast. I tried getting into bios through windows following directions i got from different online guides. I tried getting into the advanced startup but it didn't show the "UEFI" option. I also tried switching off fastboot through windows, but it didn't help either.






PC Specs: Gigabyte X570 Elite, Ryzen 9 3900x, Gigabyte 2070 Super, G.Skill 8GB RAM (X2)
 

Selynelar

Prominent
Feb 19, 2019
51
1
545
1
As I understand your concern you want to get into your uefi bios? And what would you like to set up on your ssd? Sorry if I don't understand but your inquiry is not clear for me. You mean your ssd is not recognized in the pc?

I have also gigabyte motherboard. And when you start your pc you just press delete as soon your monitor power up otherwise it will goes fast and you will miss it and it should go into the the bios. What you can set in the bios about the ssd is the priority in boot options. And that what should be in when you install windows. I mean Windows 8/10 support. There is in the boot option in the bios that fast boot enabled or disabled.
In io ports settings only what you can see is that your ssd is there.
You can try a bios reset. By load optimal bios settings and save and exit. Or if you have cmos button in the back press it for 10 seconds. Or try to update your bios.

I hope all of these helped.
 

ASK THE COMMUNITY

TRENDING THREADS