problem with the pagefile.sys

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

useing windows XP pro with a ctrl/alt/del login.
Problem is.. if you boot up the computer when you logon the profile
loads but you get the message that the swap file is too small for the
system and should be changed by going to the control pannel, system,
etc etc.. When you look the advanced tab in the system it lists the
min as 512, maximum 4096 and currently allocated as 0
if you change it so that it is either custom, or system managed it
comes up with that message and says currently allocated as 0, also
there is no pagefile.sys created on the hd.
if you change it to no pagefile then the error does not occur but the
system is slower of course.

I have tried reapplying the service pack 2 (admin), i've tried to set
it to 0 , reboot, reboot, set it to 512/4096, reboot and get the
error.
For some reason the system refuses to create this file.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Pagefile.sys is hid OS file in the root of c:
Have you tried to turn virtual memory off and then back on to reset it...?


"daryla" <zercool51@hotmail.com> wrote in message
news:1428p01o5rokp4ggpee19f4k27957at4vj@4ax.com...
> useing windows XP pro with a ctrl/alt/del login.
> Problem is.. if you boot up the computer when you logon the profile
> loads but you get the message that the swap file is too small for the
> system and should be changed by going to the control pannel, system,
> etc etc.. When you look the advanced tab in the system it lists the
> min as 512, maximum 4096 and currently allocated as 0
> if you change it so that it is either custom, or system managed it
> comes up with that message and says currently allocated as 0, also
> there is no pagefile.sys created on the hd.
> if you change it to no pagefile then the error does not occur but the
> system is slower of course.
>
> I have tried reapplying the service pack 2 (admin), i've tried to set
> it to 0 , reboot, reboot, set it to 512/4096, reboot and get the
> error.
> For some reason the system refuses to create this file.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Check this MS KB article:
Error Message: Your system has no paging file, or the paging file is too
small
http://support.microsoft.com/default.aspx?scid=kb;en;315270
--
Cheers,
Alphonse

"daryla" <zercool51@hotmail.com> wrote in message
news:1428p01o5rokp4ggpee19f4k27957at4vj@4ax.com...
> useing windows XP pro with a ctrl/alt/del login.
> Problem is.. if you boot up the computer when you logon the profile
> loads but you get the message that the swap file is too small for the
> system and should be changed by going to the control pannel, system,
> etc etc.. When you look the advanced tab in the system it lists the
> min as 512, maximum 4096 and currently allocated as 0
> if you change it so that it is either custom, or system managed it
> comes up with that message and says currently allocated as 0, also
> there is no pagefile.sys created on the hd.
> if you change it to no pagefile then the error does not occur but the
> system is slower of course.
>
> I have tried reapplying the service pack 2 (admin), i've tried to set
> it to 0 , reboot, reboot, set it to 512/4096, reboot and get the
> error.
> For some reason the system refuses to create this file.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hi, daryla.

How many hard drives do you have, and how are they partitioned? How many
pagefile.sys files do you have scattered among them?

If you have only a single volume, then you may have already tried all
available options. But if you have multiple volumes (primary partitions and
logical drives) on a single HDD, then you might choose to set System managed
size on one volume and NO paging file on all the other volumes (except
perhaps a minimal paging file on your "boot volume"). If you have multiple
physical drives, then put the System managed size on a different spindle
from your boot volume, so that the computer can write to the paging file
simultaneously with read/write head activity on the main drive.

One little quirk in this procedure causes us a lot of grief. After choosing
your settings on that Virtual Memory (Change) page, we must click the Set
button for EACH volume, after choosing the setting for that volume. So,
start at C: and go down the list and set each volume to No Paging File, then
click Set for that volume, then go to the next. After all are set to zero,
go back to the one where you want the PF to be and either set the Custom
size or System managed size for that one, click Set, then OK your way out.
(You must, of course, have enough space available on the chosen volume,
which is shown on this screen.)

As you probably know, the default ("Recommended") size is 1.5 x installed
RAM. And it is a Hidden, System file in the Root of the chosen volume.
With 1 GB of RAM, I've chosen to put mine on Drive X:, a logical drive on my
second HDD, so its name is X:\pagefile.sys and it is 1,609,785,344 bytes,
with SH attributes. I can see it by opening a "DOS" window and typing Dir
X:\ /a (the /a switch shows all files, including Hidden and System files).

One thing that the system does not do automatically is delete former paging
files. So you may find pagefile.sys in the Root of several different
volumes. These are paging files that were used before you changed to your
current file. Unless the file shows the date (today?) and the time you last
rebooted, it's the wrong file; it's no longer in use and should be deleted
to free up disk space.

RC
--
R. C. White, CPA
San Marcos, TX
rc@corridor.net
Microsoft Windows MVP

"daryla" <zercool51@hotmail.com> wrote in message
news:1428p01o5rokp4ggpee19f4k27957at4vj@4ax.com...
> useing windows XP pro with a ctrl/alt/del login.
> Problem is.. if you boot up the computer when you logon the profile
> loads but you get the message that the swap file is too small for the
> system and should be changed by going to the control pannel, system,
> etc etc.. When you look the advanced tab in the system it lists the
> min as 512, maximum 4096 and currently allocated as 0
> if you change it so that it is either custom, or system managed it
> comes up with that message and says currently allocated as 0, also
> there is no pagefile.sys created on the hd.
> if you change it to no pagefile then the error does not occur but the
> system is slower of course.
>
> I have tried reapplying the service pack 2 (admin), i've tried to set
> it to 0 , reboot, reboot, set it to 512/4096, reboot and get the
> error.
> For some reason the system refuses to create this file.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

covering all the replys.. and thanks to everyone for the responces

Alphonse, i have read the article and unfortunately it only covers
changeing the pagefile.sys or resetting it. It doesnt cover when it
will not reset under normal circumstances.

Nick, I have tried turning it off and resetting it after a few
reboots, that doesn't work. and I know where the pagefile.sys should
reside.. with attrib command you can see if it is there and it is not.


RC, there is only one HD in the system a 40gb.. if you go to a CMD
prompt you can just type attrib and it will show all files and what
their attributes are,
one thing i tried was.
booting the computer up said pagefile.sys too small.
attrib the root c: - result no pagefile.sys found
check under system/ properties/ etc swapfile shows as 0
changed it to no pagefile
reboot
computer doesn't complain about swapfile being too small.
turn swap file to manual 512/4096
reboot
computer says swap file is too small.. check system shows that it's
at 0 check attrib no pagefile.sys found.
set it to zero.. reboot

so... figured maybe the system couldn't create the file name or it's
being used so would try to create one.
drop to CMD.. copy con pagefile.sys - Enter - Ctrl Z
attrib pagefile.sys +h +s
then check.. Attrib
pagefile.sys is there with the system/hidden/archive attributes with
1k file length.
reboot
go to system/properties/etc change the file to 512/2056
windows says there is a pagefile.sys already do you want to erase it.
hit yes..
reboot..
system says pagefile.sys is too small... system says it's 0 length..
attrib says no pagefile.sys on the c drive anymore.

The only thing i havent done is to add a HD to the system to try and
create it on an alternative HD but leaveing a HD in the system for no
reason other than to host a 1-4mb swap file would be stupid and
costly.