Question Problem with USB wireless adaptor

Hyak

Reputable
Aug 24, 2016
2
0
4,510
0
Hi, first of all, I'm not the one with the problem listed below, I'm just trying to help my friend because he doesn't know how to.

My friend bought a PC from amazon (win10 installed) and at home he couldn't connect to the internet through a cable (bc of some weird space problem) so he got himself an USB wireless adaptor and everything worked for a few months.

Yesterday 15.04.20; he told me that he wants to reinstall his win10, because his CPU didn't show up in dxdiag and the PC worked 'okayish' for its components. So I went into his PC using ultra viewer, dl the latest MediaCreationTool from microsoft site, dl win10 pro, and created a bootable USB stick with Rufus. The installation went smooth, no problem/error shown, but when we got to install the basics stuff like winrar, his PC couldn't connect to the site, saying Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID.

So I tried to connect to other pages, it seemed that the PC connected to all the https:// but every http:// sites were throwing this error. After testing more sites, I tried to search on google the problem (and searched A LOT), so many answers were saying to fix date/time which was set correctly on his PC, I tried changing the DNS to the google public DNS (8.8.8.8, 8.8.4.4), still didn't worked. The problem is that he can't connect to some sites and also I saw that every app he downloads that are trusted, like nvidia driver, always throw windows defender smartscreen warn, that the publisher is unknown, and need to proceed on my own risk to TRY to install it (it just dl until 100%) then closes without error and no installation (I quess bc the app can't connect to some essential site?), even dl google chrome throws windows def smartscreen. Everything can't be trusted, whatever I download on his PC.

How do I fix this?
I tried:
  • reinstalling win10 (latest one and after seeing that it didn't work, I installed the win10 march update version, same problem)
  • flushed DNS from cmd
  • set time/date multiple times (it was correct before)
  • reset chrome, deleted cache, reset to default
  • clear ssl cache from internet options
  • uninstalled driver from device manager and restart PC
  • edit: tried with cable (router-pc) too, still same problem
The problem is that when the PC starts, it shows that the USB wireless adaptor is connected, I can go to google.com/gmail/yahoo/youtube/facebook etc.. to any https:// sites, but everytime I go to http:// it throws your connection is not private, same ERR_CERT; AND I can't use some applications like steam (friends list says friends network unreachable), can't install nvidia driver, can't install teamspeak and I guess many more bc I stopped trying; I don't think it's the win10 bc no error was thrown during installation AND the versions were clean from microsoft website, except the march update ver, which was also clean but gave the same problem; so I'm guessing the windows it's too protective for some reason or the USB adaptor it's blocking all these things.

Edit: Also he has a laptop in the house connected to the same router through wifi, the laptop works correctly.
Edit1: He tried connecting on sites that on the PC throws that error with his phone on the same router and it works. So I guess the router it's not the problem. Should I reinstall win10 without the adaptor inside the pc until after the full installation?

Thanks and sorry for the long post.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS