Question Problems began when I tried to upgrade RAM...

GalFed9339

Prominent
Dec 31, 2020
7
0
510
0
Hey there, so first off, thanks in advance to anyone who takes a whack at my problem here--any and all advice is appreciated. I have limited experience dealing with my computer, so for all intents and purposes I'd like you to regard me as a total noob.

Next, here's the machine I have:

Three years ago I bought, as a prebuilt PC, a CyberPowerPC Gamer Master GMA8840CPG Gaming Computer w/ Quad Core Ryzen 3 2300X 3.5GHz, 8GB RAM, 120GB SSD + 1TB HDD, and about a year ago I upgraded from the included Radeon R7 240 2GB to a Radeon RX 580 8GB, and a new Corsair PSU to go with it. Neither the PSU nor the GPU have ever been a problem in the year since the upgrade.

Now, here's what's gone on:

I initially wanted to upgrade my RAM from 8GB to 16GB. I looked up what I thought was compatible RAM, 2×8GB DDR4 3000MHz, and I tried to install it--I used an anti-static band to ground myself, I turned off the power strip, the PSU switch, and unplugged the power cord itself, carefully removed the single 8GB RAM and added the two new 8GB sticks.

The computer seemed to otherwise boot, but with no display. I tried the basic stuff like HDMI input-switching, unseating and switching the RAM between its two slots, resetting the CMOS battery and holding the power button, but I couldn't get back the display.

Finally, at a loss, I brought it to Best Buy. They told me that the RAM I'd bought must not be compatible with my motherboard, and I was prepared to take it home with my original 8GB right then, but they offered that they had one 16GB set left in the store they'd tested with, and it worked, and did I want to snag that RAM? So I did, I returned the first set of RAM I had bought, and a couple days later I picked up my PC from the store and took it home with the new RAM installed.

That seemed to work at first--the display was on anyway, and initially all seemed kosher. I even booted up Sekiro and played just fine for ten minutes--and then the game crashed to an AMD driver timeout.

So I moved on to trying to fix those. I used Device Manager to uninstall and reinstall the drivers, then when that gave the same driver timeout errors I used AMD Cleanup Utility to do the same, I still got driver timeouts so I did the same with DDU, still had timeouts so I tried rolling back to older drivers, had varying degrees of success, but never anything truly stable. Tried chkdsk, sfc/ scannow, various registry repair attempts--driver timeouts persisted. Reset Windows 10 locally, problems persisted, reset Windows 10 from the cloud, problems persisted. Did all sorts of tinkering with the drivers, but could never get them to perform without driver timeouts.

At one point I realized the RAM they'd put in was 3200MHz, where my motherboard is 3000MHz, so I went into the BIOS, certain that was the issue. I tried scaling down the frequency to 3000MHz, or 2667MHz (or whatever the next one down was from 3000MHz, it was something like that), I tried enabling XMP... none of that fixed the driver timeouts.

Being fully fed up by now (and if you're still reading along here, bravo and thank you), I resigned myself to just reverting to my old, original 8GB stick of RAM--I figured since I never really got it working it's not like I knew what I was missing anyway. So once again I grounded with the anti-static band, turned off the power strip, flicked off the PSU switch, unplugged the power cord from the PC, and took out the 16GB RAM from Best Buy, then replaced it with my old 8GB stick.

Aaaand that left me back with the problem from the very start: the PC seemed to boot, but it wouldn't display. I tried discharging the CMOS and reseating the RAM, even cleaning the connections with a brush and an eraser, but I couldn't get the display back. Since I hadn't gotten that issue fixed the first time either, since it was Best Buy who cleared the display problem before, and since I was becoming increasingly anxious about trying fixes as they became less and less familiar to me, I brought it back to the store at that point.

Of course, while I stood there for ten minutes, they were able to stick in my old 8GB stick of 3000MHz RAM and it booted just fine, no display issue whatsoever. They refunded me the RAM and the labor (that was nice of em) and I brought my machine home, drained but satisfied just to have the old thing back again.

At home I plugged it in, turned it on--the display worked just fine at home, the thing booted up without issues, no driver timeouts... so I went for the ultimate test: could I run Sekiro again?

It seemed to load up fine in the menu, but once loaded into the gameworld I got an ingame error, "FDP 4121," and after a few chugging frames it crashed to desktop.

From there I looked in Device Manager and saw that, though I had Radeon RX 580 display adapters in there, they were disabled. I realized they may also be out of date, since I'd been trying rolling back drivers the night prior. But I wanted input before I do another single thing.

Anyone have any ideas?

-------

This is where I'm at right now. I'm frankly afraid to touch anything, just having this much functionality feels like a tower of Jenga as it is. It may be that all I need to do is clear out and reinstall the AMD drivers now that I have the old 8GB RAM back in--or I may have to do something drastic like completely reset Windows again, I have no idea. But since I've been through all this so far, I'm just unwilling to do any more groping in the dark--it's booting up with its display intact now, and before I do anything to make it worse, I want to ask the experts here about it.

I apologize if this is miscategorized--I'm not sure if this is a "Memory" forum issue or if it belongs better someplace else, since it may not be the memory but the motherboard, or the drivers, or some other thing.

Finally, not sure whether this makes a difference, but currently my "monitor" is just an old TV I had with an HDMI. Is that possibly a source of any issues? Just mentioning.

Anyway, to anyone to still reading, thanks so much for sticking it out for this whole long post! I apologize for the length of it, but I didn't want to skip any details, having no real idea what's the actual issue. I just want to know what to do now that I've got this much functionality back, and I'm afraid to do anything to lose it...

...The only other thing I still intend to do is just try another 3D game besides Sekiro, just because the "FDP 4121" error I was getting seems to be a Sekiro-specific error, if I'm understanding what I googled. I'll try that and edit this post with the result once I've done so.

Anyway, thanks once again, I appreciate any advice! What does this have to do with RAM replacement--am I looking at a motherboard replacement, or is this something I can fix with drivers..? In other words: what's going on?

Much obliged, any and all.
 
Last edited:

Ralston18

Titan
Moderator
Look in Reliability History and Event Viewer for any error codes, warnings, or even informational events that correspond with the various problems.

Start with Reliability History: much more user friendly and provides a time line format that will help see any patterns.

1 year old Corsair PSU: Wattage ? History of heavy gaming use - correct?

How full is that 120 SSD? Is it the boot drive?

Check the motherboard's User Guide/Manual and the manufacturer's website for supported RAM and RAM configurations. Also check to see if the first physically installed RAM module must be placed in a specific slot.

Three year old system - no harm in trying a new fresh CMOS battery (noted a "reset" which I believe to mean a clearing of CMOS).
 
Reactions: keith12

GalFed9339

Prominent
Dec 31, 2020
7
0
510
0
Look in Reliability History and Event Viewer for any error codes, warnings, or even informational events...
Well, let me preface by saying the issue is solved! Though I hesitate to say I solved it, since I'm not sure what exactly I did. I'll list it for reference, though, in case some googler down the line has the same issue.

In any case, thanks for being willing to help. I was unaware of Reliability History and Event Viewer, that's good info on its own. Also, for reference, the PSU is 750W, and it does have a history of heavy gaming, yeah, though in my particular case the PSU checks out. The SSD was about 60GB full, so halfway, and yeah it's the boot drive. Also, yes, when I said "reset" I meant I pulled out the CMOS battery for a minute to reset the BIOS. I hadn't thought of replacing it altogether, though.

Though ultimately what I did is a mystery to me, cus all I did was this, which I'd only done a half dozen times before: turn off wifi and uninstall all AMD display drivers, yet again, and use AMD cleanup to be sure about it, deleting any AMD folders as well--yet again, all of this. After all that, i.e. booting into safe mode and clearing out AMD and etc, I booted back into Windows with the basic display drivers and, yet again, reinstalled the most recent AMD drivers and Adrenalin. Went through the requisite restart, and when it booted back up, I wasn't getting any driver timeouts anymore, but I had the same error message with Sekiro, "FDP 4121," and I tried another 3D game, Besiege, which would only play audio but displayed nothing.

So then I repeated everything I just described, basically because I wanted to be a thousand percent sure I did it all correctly before I moved onto anything more in-depth, and THAT was what, apparently, worked. As in, after AMD cleanup and reinstalling drivers, and still getting problems running 3D display, all I did was repeat the AMD cleanup and reinstall of the drivers again, and for whatever reason everything is solid now.

It's very possible I messed up some step the first time, and all it needed once it had the original 8GB stick of RAM back was a good clean driver install. I thought I'd done that, more than once, I mean I wrote down the steps as I did em so I wouldn't forget or repeat, but of course it's still totally possible I missed a small step each time or something. In any case, I don't know how it got fixed but I'm not complaining, and I'm leaving account of it in case someone else has the same problem, and the solution turns out to be, "just do it over a couple times." Not the solution I would have guessed, after all this--this has been my hassle for days now!
 

ASK THE COMMUNITY