Question Problems installing drivers ...win 10

diapolical

Distinguished
Dec 17, 2012
48
0
18,540
1
I am having trouble installing drivers eventhough I have the correct driver files.
Sometimes I get the message "The configuration registry database is corrupt" , and sometimes it says "cannot find the file specified".
I ran sfc /scannow and it said that it had found errors and fixed them but I am still getting the same error messages.

I should just say at the outset that if all else fails I might repair or reinstall the windows installation so there is no need to "advise" me to do that. I am looking for a more precise solution that only someone who has had and overcome this problem is likely to know.

I have the feeling that the database is not actually corrupt and the problem is elsewhere. I say this becasue of the sfc result and because the OS is performing perfectly otherwise. Windows is up to date vis-a-vis updates.

Thanks for your time.
 

diapolical

Distinguished
Dec 17, 2012
48
0
18,540
1
LAPTOP SPECS
Windows 10 Pro 2019
Lenovo Y580 laptop
8gb ddr3 PC3-12800 (800 MHz)
256gb ssd windows drive
1TB hdd storage
Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
NVideo GeForce GTX 660m
Intel HD Graphics 4000
Very nice little usb mouse

I am not confident declaring these specs will make any difference.
So far had trouble with Roccat Juke usb sound card, NDIS for android phone (to tether) and Realtek Audio.
the problem persists with or without the firewall, with or without av installed.
 
Last edited:

Colif

Win 10 Master
Moderator
"The configuration registry database is corrupt"
This refers to DISM which is Deployment Image Servicing and Management, it is a tool used to manage the windows image. the source files windows uses to install itself. Sometimes SFC is incapable of fixing all your problems so you run a DISM command to replace the files SFC uses to compare to currently running system files.
If its source itself is corrupted you can run a command to fix it.

Now Win 10 Pro 2019 doesn't really tell me anything.
Can you right click start
choose run...
type winver and press enter

Current version is 1909.

If you are on 1909 now, you can do 2 things to fix current problem
1. Download a copy of the win 10 iso from Here - create ISO by telling it you want to make DVD - and then mount that ISO in file explorer (see Here) and then copy paste the below command into command prompt (admin)


DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:\Sources\Install.wim:1 /LimitAccess

Where "X" is the drive letter where the ISO is located. Simply change the "X" to the correct drive letter

or 2. Do a repair install - https://www.tenforums.com/tutorials/16397-repair-install-windows-10-place-upgrade.html

If you aren't on 1909 now, you can't do either of those as both rely on an ISO which is the same version as what is currently installed.

If you are on an older version, I would upgrade to 1909 as that also replaces the source files. Version updates are essentially a clean install every 6 months.
 

ASK THE COMMUNITY

TRENDING THREADS