• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Problems upgrading power supply for Dell Inspiron 580

merlin123

Distinguished
Mar 3, 2011
5
0
18,510
0
Hello All,

I bought a Antec EarthWatts EA-500D Green 500W ATX12V v2.3 / EPS12V 80 PLUS BRONZE Certified Active PFC Power Supply which fits perfectly in the 580 case to replace the stock 300w PSU.

I installed it and powered it on using the back switch. The yellow light came on on the MB. When I pressed the bower button located on the front, the case fan powers on for about 2 seconds but nothing else turns on. All connections to MB, 24-pin and 4-pin are tight as well as connection to HD and DVD drive.

I reinstalled the stock 300W Dell unit and it works fine.

Before I send it back in need some information determine my future course of action.

Could this be a result of a bad power supply?

I have heard in the past that Dell was using proprietary wiring for their boards/PSUs and I don't know if this practice is still continuing. Anyone have any input?

If anyone has successfully replaced a PSU in the Inspiron 580 could you share the make and model of the replacement PSU.

Thanks so much in advance.


 

merlin123

Distinguished
Mar 3, 2011
5
0
18,510
0
I tried the 500W again with the same results.

Without putting the 500W in another computer, how can I verify that all connectors are working properly?

How can I tell if Dell uses proprietary wiring? Can I compare the placement of the wires, by color, on the connectors, between the 500W and the stock 300W?

Thanks in advance for your help.
 

Similar threads