Problems with AMD switchable graphics

Jan 15, 2019
1
0
10
0
Problems with AMD switchable Graphics

My laptop specs:

CPU: AMD A9 9420 (3.0Ghz dual core)

GPU1: (integrated) : Graphics Chipset - AMD Radeon(TM) R5 Graphics (512MB)

GPU2 (dedicated) Graphics Chipset - AMD Radeon(TM) 530 (2GB)

RAM: 8GB DDR4

storage: 1TB HDD

Operating System: Windows 10

laptop: Lenovo ideapad 320



The problem is that I noticed while playing WarThunder (a game) every time i launch it it says that my graphics card has only 512MB of memory and if i have another one that i should switch to it. After that message the game proceeds to launch and runs at about 45-55 fps. I am not too big on gaming but i have also noticed a similar message when i am using AutoCAD ( i really need this program to run well) AutoCAD wors fine besides some minor freezes every 2 minutes or so. I wanted to switch to my dedicated graphics card and went on youtube. Everyone there tells you to just go into Radeon Settings panel and change ur settings from battery saving to performance and so I did but that did not do anything since the programs were still reporting the same message when i lunch them. Then i saw one video where a guy shows you how to do it in BIOS and he basically tells you to go inot BIOS and change your graphics settings to go from god know what to PCIE. I tried to do the same but my bios was a bit different so i did not have that setting but it did have one that would allow you to go from "UMA only" to "Switchable Graphics" so i switched to "Switchable Graphics" saved the settings and rebooted my pc. I taught that this time my dedicated GPU will start working but it did not. WarThunder was still telling me i was running on my 512MB GPU (same in GTA IV graphics settings menu). Than i remembered i saw both cards in device manager and I decided to try and disable the integrated one from there. I disabled it and my screen flashed black once and the resolution changed but i fixed that. Than i was thinking that i fially made it. When i launched GTA IV to see the resaults it just crashed saying that my GPU does not support some features in the game. Than i tried launching WarThunder and the message did not appear telling me i have only 512MB of memory on my GPU but when it opened on main menu it performed horrible. I did not even enter a match but it ran at like 5 fps in the menu.

Now i have returned to all my default settings but cant figure out why did the dedicated GPU perform so bad or if it even turned on after i disabled the integrated GPU.

If you guys need some more details on my gpu's and my cpu (like bit rates etc) i will post them in the comments.

 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS