Question Problems with ASUS Realtek HD Audio

gdmaclew

Distinguished
May 20, 2008
1,389
7
19,465
96
I am having a problem with the HD Audio driver/app on my new ASUS TUF x570 Pro motherboard.
The specs and manual of the MB say it has the Realtek S1200S HD Audio chip.
But Device Manager shows 2 entries - AMD High Definition Audio Device and High Definition Audio Device under Sound, video and game controllers.

ASUS says they are looking into it. I have gone to the Realtek website and downloaded v 2.82 of their HD Audio Driver and tried to install it but I get a 0001 error.

What's also missing is the Realtek HD Audio Manager I was used to on my previous Windows 7 PC that is still operational (ASUS 970 Pro Gaming Aura). The software that gets installed with the TUF board is a far cry from that Manager.

Tom's did a review of this motherboard in November and made reference to " Realtek ALC S1200A audio codec (albeit an Asus’ tweaked version), which is capable of 7.1 surround and DTS ausio".

DTS app is available on my new PC but it is bare bones.

This is not a major problem but I would like to sort it out.

View: https://imgur.com/a/eB0cdOc


Thanks.
 
Last edited:

gdmaclew

Distinguished
May 20, 2008
1,389
7
19,465
96
OK. I think I solved this problem.
When I first set up my new PC (using Media Creation Tool and booting f rom the USB thumb drive) the fist thing I did after Windows 10 was installed (or I thought I did) was to install the ASUS TUF X570 Chipset Drivers and Audio Drivers.
Well it turn out maybe I didn't or it didn't work because just on a whim I inserted the driver/utility CD that came with the motherboard and this is what I saw...

View: https://imgur.com/a/rm9v9H9


So I just ran it again selecting the first 3 items.

After they installed and the PC rebooted a couple of times Device manager under "Sound" was just slightly different, Show a Realtek Audio Device.

View: https://imgur.com/a/pzDOkTN


Now, I guess I was used to having the Realtek HD Audio Manager in my System Tray on my old PC so I was expecting it to be there onmy new PC. But since it's not I just Pinned the new Realtek Audio Console and DTS Custom Console to the Taskbar.

Problem solved.

Now on to the next one...
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS