[SOLVED] Problems with Edge signing me out of sites and password problems since updating

Status
Not open for further replies.
Jul 23, 2020
7
0
10
0
2 Problems
  1. Ever since I updated Microsoft Edge (KB4559309) I've run into problems of it signing me out of web sites after closing the browser. Most of the time this isn't a real big problem except sites like Amazon where I have to do a 2 step verification each time. Is there a way of setting to keep Edge from signing me out? I've already changed setting suggested in other sites with no luck.
  2. After the update all of my bookmarks and passwords vanished. I managed to import my favorites and bookmarks but have not been able to import any of my passwords. They are still in the control panel credential manager. Is there a way to import them without having to go to all of the sites (dozens if not a hundred) and manually logging in and saving them?
 

Colif

Win 10 Master
Moderator
  1. So there was a fix for that on the old version of edge, but the choice doesn't exist in current New Edge - see post by Berkan, you can find the menu he suggests in settings/privacy & settings/Clear browser data but the option he shows tro turn off - Always clear this when close browser - doesn't seem to exist in new version, but the behaviour you mention does... https://answers.microsoft.com/en-us/windows/forum/all/microsoft-edge-keeps-logging-me-out-of-my-accounts/c717e29a-5631-4930-af4f-450b12888944?page=2 - I don't see anything for the new one. New one being basically Chrome with a few extras/changes.
  2. Did you try to import your profile from Internet explorer as it should have gathered all the passwords. It saved all the ones for my mum which is handy as I bet she doesn't know them.
 
Jul 23, 2020
7
0
10
0
  1. So there was a fix for that on the old version of edge, but the choice doesn't exist in current New Edge - see post by Berkan, you can find the menu he suggests in settings/privacy & settings/Clear browser data but the option he shows tro turn off - Always clear this when close browser - doesn't seem to exist in new version, but the behaviour you mention does... https://answers.microsoft.com/en-us/windows/forum/all/microsoft-edge-keeps-logging-me-out-of-my-accounts/c717e29a-5631-4930-af4f-450b12888944?page=2 - I don't see anything for the new one. New one being basically Chrome with a few extras/changes.
  2. Did you try to import your profile from Internet explorer as it should have gathered all the passwords. It saved all the ones for my mum which is handy as I bet she doesn't know them.
I saw that post before and it didn't help, the screens and options are a little different. I still have the problem of having to sign in to every site whenever I close edge or start up.
I tried your suggestion and imported just the passwords from IE and that worked. I got all of my passwords back into edge. That helped a lot, thanks.
I'll still have to work on the logging out problem.
Thanks again
 
Jul 23, 2020
7
0
10
0
It was nice while it lasted. All of my passwords were imported and showed up in Edge. After startup this morning all of them disappeared. Imported them again along with the bookmarks from IE 11. Shut down because I had an appointment to keep and when I came back logged on they were there. After another shut down and they were gone again. Seems like they save whenever they want. Still cant stay logged in to any site.
 

Colif

Win 10 Master
Moderator
I assume everything is turned off on this page - edge://settings/clearBrowsingDataOnClose

its like the setting that doesn't exist in the current version is set as on and its resetting all your fav on restart

I don't think this is for the new version still as it mentions turning off the option which I can't see
Microsoft Edge doesn't clear the browsing data by default when it closes. Browsing data includes information entered in forms, passwords, and even the websites visited.

If you enable this policy, all browsing data is deleted each time Microsoft Edge closes. Note that if you enable this policy, it takes precedence over how you configured DefaultCookiesSetting

If you disable or don't configure this policy, users can configure the Clear browsing data option in Settings.

If you enable this policy, don't configure the AllowDeletingBrowserHistory or the ClearCachedImagesAndFilesOnExit policy, because they all deal with deleting browsing data. If you configure the preceding policies and this policy, all browsing data is deleted when Microsoft Edge closes, regardless of how you configured AllowDeletingBrowserHistory or ClearCachedImagesAndFilesOnExit.
https://docs.microsoft.com/en-us/deployedge/microsoft-edge-policies#clearbrowsingdataonexit

If you have WIn 10 Pro you could use GPedit to change the policy. Home users don't have that choice.
 
Reactions: BigTBen
Jul 23, 2020
7
0
10
0
I have all of the delete on exit setting turned off. For the last couple of startups my passwords and bookmarks were still intact but that could change with the next shut down.
I tried going through the articles but not having any real experience programming I'm at a loss as to how or what changes need to be made.
For now I'm using chrome for the few sites that are a pain to keep signing into (2 step verification etc.).
I may have to look into different browsers as my main one.
Thanks for taking the time to help me and for your suggestions.
P.S. Could a VPN be causing some of these problems? I'm using the same IP at startup. I'm not having this problem with Chrome so I'm tending to eliminate the VPN as a cause.
 

Colif

Win 10 Master
Moderator
I swapped from Chrome to Edge and copied all my settings over and it didn't have any problems. Mind you, side by side, there isn't a big difference



So it must have been something it got wrong when it imported your settings across.

You could try resetting it to default settings as the default is meant to be off, it might cancel out whatever is happening - https://malwaretips.com/blogs/reset-microsoft-edge/
 
Reactions: BigTBen
Jul 23, 2020
7
0
10
0
Resetting had no effect. It looked like it was working for awhile then it logged me out again. Even sites like yahoo get logged out. It logs me on shutdown and sometimes just closing Edge will log me out.
 

Colif

Win 10 Master
Moderator
At this point, I feel the only people who might know an answer to this are Microsoft so you could try asking on their Edge forum - you might find these people have an answer as well - Tenforums - I would link to this thread there so they don't repeat advice :)

Its probably that your user settings are on your user profile itself, it could explain why it logs out on shutdown, but I don't have a simple answer to this. I could guess a registry change might do it but I have no idea where. I don't normally go into it.

If you do find one, let me know :)
 
Reactions: BigTBen
Jul 23, 2020
7
0
10
0
I didn't find much on Tenforums but there were some tips in the edge forum. One post claimed to fix this problem by going back to Windows 10 build 1909 from the May 2020 verision. I could not try this because my update is more than 10 days old (no option to go back).
Another was to install Edge DEV. I did this with no big results. I removed Edge and Edge DEV. reinstalled Edge DEV. Not much difference until I disabled my VPN. Now on startup I'm still logged into Yahoo and Amazon. The only thing now is that it seems the Edge DEV has been having a selective memory when it comes to saving passwords (sometime their there and other times their not.
I'm going to contact my VPN provider to see if there is something they can do.
Thanks to everyone for their help and suggestions.
 
Jul 23, 2020
7
0
10
0
Finally fixed for the most part.
  1. After contacting my VPN provider I had an older version installed. This stopped some of the problems.
  2. After a few 1 h-2 hour sessions with Microsoft agents Windows 10 was reinstalled, The new version of Edge was removed and an older version installed.
This cleared up the problems with Edge losing my passwords.
I still have a problem with Chrome (have to log into my account each time I shut down to sync my passwords) and with no way to contact them that I could find I just uninstalled it.
I may try Chrome later (a few months from now) and see if it's still the same.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS