Question Problems with latest graphics drivers

Mar 25, 2020
4
0
10
0
I had a few problems with my previous rx 590 so I reclaimed it and got a new one. The new one ran great for 1 day and than, after installing newest drivers from amd it started coilwhining (not the usual way, I am limiting my framerate to 120FPS and it still coilwhines as hell on blurry things like CS:GO´s buying menu etc.) +it extremely lagged my screen (VSync was on and it looked like I was playing on 15FPS, but the FPS indicator showed that I am not).

Since installing the newest drivers I started getting errors like DRIVER IRQL NOT LESS OR EQUAL and many more. I tried reinstalling the drivers with DDU Driver tool (even to older versions of the drivers to know if the new released drivers weren´t faulty) but It didn´t help. I noticed also that I have more FPS without drivers than with them (I am not talking about 2-10 fps, the change is about from 50-90 depending on the game). What should I do ?

SPECS:
Ryzen 5 2600 (not overclocked)
ASRock RX 590 (not overclocked)
16GB DDR4 3200mhz
Zalman ZM600LX (can´t reclaim it because of COVID-19)
 
Apr 18, 2020
8
0
10
0
Hello, have you tried to check the graphics and video settings of Radeon software ?
Like for exemple FreeSync and other settings, maybe it could help
I know that i used to get some weird things on ForHonor for exemple, it was showing +100fps but it was laggy so i have to Alt+tab, but i found that i just needed to play on Fullscreen and to use to right refresh rate of my screen, and to change also on Windows: Settings -> System -> display -> below you have advanced display settings -> properties of video card for display 1 -> screen -> and here you put the refresh rate of your screen.
I don't know if it'll repair your problem, tell me
 
Mar 25, 2020
4
0
10
0
Hello, have you tried to check the graphics and video settings of Radeon software ?
Like for exemple FreeSync and other settings, maybe it could help
I know that i used to get some weird things on ForHonor for exemple, it was showing +100fps but it was laggy so i have to Alt+tab, but i found that i just needed to play on Fullscreen and to use to right refresh rate of my screen, and to change also on Windows: Settings -> System -> display -> below you have advanced display settings -> properties of video card for display 1 -> screen -> and here you put the refresh rate of your screen.
I don't know if it'll repair your problem, tell me
It didn´t but thanks for your reply anyway :)
 

ASK THE COMMUNITY

TRENDING THREADS