Problems with Memtest86+

-Nemesys-

Distinguished
Apr 12, 2009
10
0
18,510
0
Hey everyone.

I am currently experiencing 'technical difficulties' using memtest86+.

The problem, is that memtest v1.x and v2.x will 'freeze' (?) upon loading.

The strange thing is that I've used memtest briefly b4 about 2 or 3 months ago. I ran a whole pass 100% with No errors - With this current setup; my hardware (and mostly software) has Not changed.

I have been building / repairing / refurbishing desktop PCs for many years now, mostly as a hobby or as a favour, however I am totally stumped atm.

The reason I'm trying to run memtest is because I owned a Very corrupted Seagate IDE hard drive for about a year; that's approx. how long it was 'bad'... So, sick of having this persistent problem, I bought a new SATA HD.
I explained to the guy at the shop that my hard drive was corrupt, that it was definately the drive, it had started to die a year ago and now was at the point where even <500kb jpeg images were going corrupt (I could 'see' the corruption just by looking at them).
I was sure it was the hard drive - I had even downloaded a utility from the HD manufacter which Failed the SMART check (strange, as it was reported 'OK' in system startup) but the guy said I should maybe check my RAM - which btw I purchased from him about a year ago, around the same time my HD got initially 'Fried'. So BEFORE installing the new SATA drive, I made a USB stick bootable, with Memtest86+ on it.
I can't remember which version I used at the time, tho I think it was the newer one, v2.11. In any case it worked fine; my usb booted win98's DOS and loaded Memtest ok. I let Memtest run a full pass, JUST TO BE SURE it wasn't my RAM causing data corruption. It achieved 100% with NO errors before installing a new HD.
Right after I was confident my RAM was ok, I opened the seal on the bag of my new SATA HD and installed it happily. No problems, it was installed quite smoothly. I inserted the XP SP2 CD and full-formatted it anyways, just to be sure; I then used partdisk to delete the main partition, and make 2 partitions - one for windows, and one for music, pictures, etc which I obviosly didn't want to lose if I had to reformat; I full-formatted these partitions as well.
I installed XP (which I've done like 50+ times over the years btw ;) and eventually downloaded some resource-heavy games I had working on my old HD such as Elder Scrolls 4: Oblivion, F.E.A.R., GTA San Andreas.

Oblivion (VERY resource-heavy) hasn't caused any stop errors, nor has F.E.A.R., but San Andreas HAS, AFTER having it installed on my PC for over a month or 2.
When I first ran into a BSOD after replacing that corrupted hard drive, I didn't think too much of it as XP has never been 100% functional. But when I saw them again and again (about 2-3 days or almost a week or two apart on average) I wrote the stop error down, along with the stop number (ie*** STOP: 0x000000 etc) and googled it.
Unfortunately, I haven't found any good websites to tell me exActly what the problem was. What I did find is at least two websites giving me the impression it Might be something to do with the RAM.
So far, I've basically shrugged this off and not played this game much. But now I am experiencing Some BSODs randomly, sometimes during shutdown, sometimes during startup (after the XP screen, b4 the user login screen), and sometimes just randomly while only listening to my music (winamp).

What is REALLY bothering me is that the Blue Screen of Death is not 100% blue - a small section of it in the lower-right area (approximately 3 lines of text high, same width) is PINK with a few random pixels - GLITCHY!?! This has happened more than once, but less than 10 times.

I wrote down this stop code, and googled it as well, again suggesting that I check my RAM. The stop code is as follows (please note that the spacing is for easier reading ;) :

PAGE_FAULT_IN_NON_PAGED_AREA

***STOP: 0x 000 000 50 (0x FFF FFF EA,
0x 000 000 01,
0x 805 255 B4,
0x 000 000 00)

Just to recap,
- after replacing my HD, my first BSODs did NOT have a pink 'patch' in them, and were i THINK 100% "BAD_POOL_CALLER"s
- after some time, I noticed my BSODs had a pink patch, while they were still "BAD_POOL_CALLER" stop errors
- now my last BSOD (I believe during shutdown) was the stop code I wrote above - the "PAGE_FAULT_IN_NONPAGED_AREA"

Sooo, again I'm TRYING to test my RAM, but this time let Memtest86+ run all night to perform more than just one pass. I am booting into Win98 DOS with my USB key, and trying to open Memtest via DOS. Memtest will OPEN, giving me the memtest86+ screen with NO text except on the top of the screen where it reads "Memtest86+ v2.11" or whatever version I am running.

It seems like Memtest86+ 'freezes' during loading, although the "+" sign is still flashing regularly as it should be... It seems to me like my PC isn't actually 'frozen', nor is Memtest86+, but I can't Ctrl+Alt+Del to restart, and waiting 10 minutes or so brings me nowhere..... I DON'T GET IT. Last time I ran Memtest86+, upon opening it loaded Very quickly and gave me options (ie to run memory test, to exit, etc). This time, I get no options. And yes - I tried redownloading Memtest, saving it in different locations so it would actually re-download etc. No Luck.

I tried to work around this issue by trying different versions of Memtest86+; I tried ALL versions available for download, including 1.65, 1.70, 2.00, 2.10, and 2.11, each time restarting and loading DOS first via my USB key, and opening Memtest.

Version 1.65, upon opening, restarts my PC instantly with no blue screen.

All other versions get the same symptom upon loading - no progress, no text except the headline "Memtest86+ vX.X" (where X.X is the different versions I tried), no options, nothing but a blue screen with the "+" sign still flashing in the title... and yes I tried hitting any key, including enter ;] - NO RESPONSE, NO PROGRESS. No memory testing.

I also tried loading Memtest86+'s pre-built .iso(s) onto my USB key when making it bootable (I am using "HP's Drive Key Boot Utility" primarily, while I also tried "HP's Disk Storage Format Tool" which gives me the option of making it bootable - this method worked last time I was able to run Memtest).
PS No, I didn't just copy the .iso file and paste it onto my USB key; I managed to A) make my USB key bootable, B) using HP's software and Memtest's ISO images. Upon startup, my PC would boot from USB and TRY to load Memtest but again, it would get caught up.
Using this method, I have no DOS and Memtest starts automatically. Unfortunately, I only get to see the "Loading......." message, but Memtest never actually starts; it just 'freezes' after spewing out about a dozen "."s to indicate progress... waiting does not help with this either.

:fou: :fou: :fou:

Like I said, I've ran at least ONE of these versions of Memtest86+ successfully before (once I figured out how to make my USB bootable for my first time). Now I'm just stumped, a little confused, and a quite agitated.

So, a few questions for you experts out there would be:

A) Why is Memtest doing this - 'freezing' (?) no matter what I try?
B) Has anyone had / heard of this problem b4?
C) Can these BSODs cause my new SATA HD to have mechanical / technical problems like data corruption / loss etc.? / is this bad for my HD and if so, how bad?
D) do You think my RAM (also fairly new) is at fault here?



Here are my stats / hardware / software:

- Asus P5VDC-MX series mobo; about 2 maybe 3 years old,
- Intel Pentium 4 CPU @ 3.00GHZ (2 processors)
- 2 x 512MB DDR2 RAM (@ 433khz I believe) by 'Kingston', purchased new about 1 year ago
- ATI Radeon Sapphire x1600/x1650 Series video card (8x AGP, 512MB), purchased new about the same time as my RAM
- a used 16-bit Sound-Blaster PCI card
- Seagate's Barricuda 80GB SATA HD, partitioned into 2 drives (40GB each), purchased < 2 months ago
- Another older 80GB IDE HD, which has not caused any problems in the past to my knowledge

- XP Home Edition (5.1, build 2600, SP2)
- Catalyst Control Centre (comes with video card)
- typically nothing else but MSN v7.x, winamp, and occaisionally the odd game

PS Thanks for any answers, suggestions, and comments! ;]~
 

ASK THE COMMUNITY