Problems with my month old build

xbigb78x

Prominent
Jan 20, 2018
3
0
510
0
I can home last night (extremely drunk) And was going to show my friend my new pc and allow him to play pubg. I started it up like normal, was showing him desktop backgrounds from wallpaper engine off steam. Loaded pubg, got a weird message about BP being given to me and then BAM! Black screen dead system, the only light that turns on is my LED that is by my power supply and it flickers (on for a little bit, flickers/flashes, solid again, ect), no fans spin, nothing. Any suggestions would be lovely as I dropped $900 into this build about a month and a half ago and now I'm dead in the water.
 

xbigb78x

Prominent
Jan 20, 2018
3
0
510
0
Quick updste, removed my SSD and then tried to turn everything back on, the LED on the motherboard turns on for a split second then everything goes dark and won't turn on until I unplug the power supply
 

InvalidError

Titan
Moderator
A flickery 5VSB LED would indicate either that something has gone wrong with the PSU or something connected to 5VSB elsewhere in the system is shorting 5VSB out.

The PSU refusing to turn on again is usually because one of the PSU's protections got tripped and caused the PSU to go into lock-out to hopefully force people to investigate the fault instead of mashing the power button hoping for a different result and possibly causing more damage by doing so.
 

xbigb78x

Prominent
Jan 20, 2018
3
0
510
0
But, if the 5VSB was staying on but fluckering and after the ssd was removed it when into lock down state I'm wondering if it is my psu.. I mean everything was fine up ubtil I bought two crates on PUBG test servers and then all went black... I hope it's not my cpu or graphics...
 

ASK THE COMMUNITY

TRENDING THREADS