Question Problems with my new graphics card

Dec 11, 2019
4
0
10
0
I bought a EVGA gtx 1060 6gb card i know it’s an average card but anyways let’s get to the topic at hand I bought it two weeks ago off of EVGA during midweek madness i got it last week and I’ve been using it for the last week it’s been running perfectly, been playing battlefield v as well as the new Star Wars game on high. Today I was playing fifa 20, a game that isn’t very demanding, I’ve played on it more often than the other games throughout the week, and my pc just turned off during the middle of a game. I tried to turn my pc back on and it would turn on but the graphics card wouldn’t light up and the display wouldn’t show either so I tried to restart my computer no change, eventually I changed my hdmi cable to the motherboard connector instead of the 1060’s and everything worked fine. I’m pretty new to PC stuff this is my first build actually that I had started during the summer that I’m finally getting to finish, so what happened to my graphics card and how can I fix it or what’s wrong with it I suppose.
 
Dec 11, 2019
4
0
10
0
CPU- AMD Ryzen 3 2200G
Motherboard-Gigabyte B450 smh
RAM- 8GB G Skills Rip Jaws 2400 Mhz
GPU-EVGA GTX 1060 6GB
PSU-EVGA 80+ White 500W
Monitor-SCEPTRE-E205W-1600BR 20” 75Hz
 
Dec 11, 2019
4
0
10
0
What's the model number of your motherboard?
Have you rechecked the power connection to the graphics card to make sure it's secure?

-Wolf sends
I’ll do that again when I get back home and see whether or not it’s secure I’m at school rn but yeah I’ll update y’all on that
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts