Question Problems with new Corsair Virtuoso XT headset ?

Mar 5, 2022
2
0
10
0
I work from home. We use a server that fields calls to us that has to be used through Chrome (or Chromium in general, I suppose). So all of the stuff needs to be used through Chrome/Chromium. But the headset makes it go soooo slow. The server usually shows what your headset/mic is, but will not work with this headset. (Primarily uses Twilio). These are the ONLY headphones that this happens to. I had a Razer Kraken V3 Pro before this (dont even get me started on that headset, the issues and THX).

Same with Google Meet. It will eventually connect, but it takes forever. If I disconnect the headset or use a different headset, Google Meet and our server loads right up.

Youtube will even lag, and sometimes just not play videos.

The headset works perfectly fine with any other application, like Discord.

I tried uninstalling ICUE, and the server picked it up, but sound through say YouTube or even testing in the settings just skips and doesn’t work without ICUE.

The only way I can fix it and make Youtube/Meet/anything through Chrome work is to uninstall Corsairs drivers, but whenever another update comes out through ICUE or the headsets firmware, the drivers get installed again and I have to uninstall everything each time.

Would anyone know what may be wrong with my headset and these web browsers? I know it’s a long shot but I like this headset and not sure what else I should do.

Specs:

MOBO: ASUS Rog Strix B450F Gaming on latest Bios. Just updated today.

Processor: AMD Ryzen 5 3600 6-Core Processor 3.70 GHz

Installed RAM: 16.0 GB

GPU: EVGA Nvidia RTX 2060 KO Gaming Ultra

System type: Windows 11, 64-bit operating system, x64-based processor
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

For the sake of relevance, what version of Chrome's browser are you working with? As a side note, if you're working with this headset, have you tried installing the latest iCUE app in an elevated command, i.e, Right click installer>Run as Administrator?

Have you tried working off of Edge or any other browser based off of the Chromium project? For the community, could you please state the BIOS version?
 
Mar 5, 2022
2
0
10
0
Latest version of Chrome. I’ve uninstalled and reinstalled and checked to make sure it was up to date.

I’ve run ICUE as Administrator, same with Chrome, no change.

Bios version is 4702.

Headset and Dongle’s firmware is up to date, same with ICUE.

I’ve tried Edge, Chrome, Firefox, and Brave. None work.

I did get it to work though by running Chrome in Compatibility Mode for Windows 8, oddly enough. But Chrome is ugly as sin with the bright white top of the window. >.>

I’ve reinstalled the USB drivers, did a clean install of Windows, made sure all drivers are up to date.
 

ASK THE COMMUNITY

TRENDING THREADS