Question Problems with new Seagate hard drive connection/disconnections

jasondwoods2

Prominent
Apr 12, 2018
15
0
510
0
My PC build: https://pcpartpicker.com/list/LK9cyk

This problem dates back about a month or so, so bear with me. I built this PC about 2 years ago, and originally had two of the WD Blue 2TB drives installed with absolutely no issues involving either of them, one for my OS and one for games. About a month ago, I decided to replace my secondary HDD (used for games) with a larger drive just because I wanted more storage space, which would be the 6TB BarraCuda. After formatting the new HDD in GPT, everything worked perfectly fine for about 1-2 weeks.

After that, the secondary HDD started randomly disconnecting, which would automatically close most games I was playing. It would reconnect a second later, and the prompt to choose what to do with the drive would appear. I followed various forum tips and guides, but still had the issue. The HDD showed up fine in Disk Management and BIOS, and I could reformat it but to no avail. I decided to replace it with another 6 TB BarraCuda, which worked perfectly fine for another 1-2 weeks until yesterday.

This new one worked perfectly fine for about 1-2 weeks just like the first one, but started disconnecting randomly within the last day or so, but I don't even get the prompt to use it when it reconnects. I only even noticed it was disconnecting because, while downloading games on Steam, I noticed disk write errors were stopping my downloads. Sometimes the drive shows up in 'This PC', sometimes it doesn't; same with in BIOS.

I also had a weird issue when trying to look at it in Device Disk Management, where it became uninitialized. I couldn't initialize it, as I got an I/O error whenever I tried. Same thing happened when trying to use DiskPart to clean it. Trying to check the disk using Windows' error checking function wasn't able to go through either. There would also be popups about the location missing when trying to access the drive and its folders.

As of right now, this hard drive which was previously working just fine is now uninitialized, and cannot be initialized to be reformatted because of that I/O error. I have also gotten two BSODs within the past couple hours which say "Kernel data inpage error". Event viewer has some posts related to kernel-power and bugcheck, screenshots are here: View: https://i.imgur.com/XakKokI.png
and View: https://i.imgur.com/bRYby2H.png


Fixes I have attempted include swapping the SATA cables, swapping the SATA ports used by my main OS dive and the new HDDs, running CheckDisk and PartDisk, reformatting the first drive(unable to do so on the second due to the I/O error), and running SeaGate's SeaTools program to try and fix the drives. I also checked CrystalDisk, and while my main C drive(with OS) shows up as good, the problem drive (D) doesn't even show up in the program.

(Hopefully) Relevant screenshots: View: https://imgur.com/a/ZSQ75


Something else of note(not sure if it'll help), I used SpeedFan and OpenHardwareMonitor to check my temps, and each showed that one part of my Nuvoton chip was reaching 97 C, whereas the other 3 parts would remain cool at around 28C. My temp readings for everything else were normal, and same with the temps shown in BIOS for CPU and motherboard. I'm not sure if this is significant or not.

Something else I noticed, is that when my computer has to do anything that involves accessing that second drive, the program trying to do so hangs really badly. This involves trying to open the drive and its folders in File Explorer, or Disk Management and third party programs trying to rescan the computer for available drives. Even just opening Disk Management takes a hot second for it to detect my available drives.

Thanks in advance for any help or advice.
 

ASK THE COMMUNITY

TRENDING THREADS