Question Problems with pc detecting ethernet connection

jasondwoods2

Commendable
Apr 12, 2018
16
0
1,510
0
OS: Windows 10 Home
Adapter: Intel (7) I219-V
Motherboard: ASUSTeK ROG STRIX Z390-E Gaming

I moved into an apartment near my school for the fall, and when I returned home for my Thanksgiving and winter breaks, I found that my PC is unable to connect to the internet via ethernet cable, with my network connections screen saying that the ethernet cable is unplugged. This connection worked perfectly fine this summer before I went to school (as well as while I was at school), and I'm using the exact same cable and setup as I did then. Essentially, I connect a smaller ethernet cable between my PC and the wall outlet in my room, which runs a very long ethernet cable down into the basement where the router is. I know that the port on my pc, as well as the smaller Eth cable, are operational, because they could connect perfectly fine to my school's internet just earlier today before I returned home. My pc connects just fine to the wi-fi, but it is fairly slow, hence why I'd like to regain my wired connection.

The ethernet port on the back of my pc doesn't light up when the cable is plugged in. I also noticed in 'ipconfig' that my ethernet adapter's DNS suffix is still stuck on my school's network, which I wasn't sure if that meant anything or not. I also updated the drivers for the adaptor to no avail. I know that the longer cable going from the wall outlet to the router might be the issue, but since it will be a pain to replace I was hoping I could check here first and see if anyone has any ideas on what to do. Windows troubleshooting just tells me that the cable is unplugged.

I also tried the steps in this guide: https://support.pearson.com/getsupport/s/article/Reset-an-Internet-Connection-Flush-DNS#win10
Here is a screenshot of my ipconfig info, if it helps at all: View: https://i.imgur.com/Mh7rume.jpg


If any more information is needed, let me know. Thanks in advance!
 

jojesa

Illustrious
Make sure the Ethernet cable is working properly or use a diferente cable.

In case your school changed the Ethernet properties, follow this steps to revert the changes.
Click the 'Start' menu and select the 'Settings' icon.
Click on 'Network & Internet' in the Settings window.
Select 'Change adapter options' on the right pane.
Double-click the 'Ethernet' icon in the Network Connections window.
Click on the 'Property' button in the Ethernet Status window.
Double-click the 'Internet Protocol Version 4 (TCP/IPv4)' on the Ethernet Properties window.
Select 'Obtain an IP address automatically'
Select 'Obtain DNS server address automatically' or use the following DNS servers 8.8.8.8 and 8.8.4.4.
Click OK, OK then Close.
Reboot.
 
So there's two tests you can do without having to start diagnosing the long cable.

One, find some dumb unmanaged switch of any speed (even 100Mbps is fine) and plug it into your jack and see if any link lights light up. If so, proceed to the next test. If not, go downstairs and see if someone unplugged the cable (hopefully it was just something simple like this).

Next test, boot your system using a linux live cd/usb and see if you ethernet works in that environment. If so, then it's a windows driver issue. If not, something might have happened to your nic during transportation.
 

ASK THE COMMUNITY