Problems with Radeon HD 8750M

Aflow

Reputable
May 4, 2014
2
0
4,510
0
Hello everyone, Just recently bought an Acer Aspire V5-552G-X412. It came with windows 8 instantly changed it to windows 7 64bit. My problem is after updating all the drivers When i run DXDIAG it shows my display is RADEON 8650G which is the onboard. before i installed windows 7 i ran DXDIAG and it showed the 8750M which is the secondary graphics card. Anyone know how i can get the 8750M to work? Device manager Picks up both AMD RADEON 8650G AND AMD RADEON 8600/8700M which is the one i want of course. Also dual graphics in the catalyst contol center is checked.

UPDATE: I uninstalled all framework and the drivers and re installed. now in CCC under information>Hardware it shows the 2 graphic gards but the onboard 8650G is the primary and the 8750M in the linked adapter. Also under when I run DXDIAG and click the display tab the device is still 8650G. Please help, Thanks.
 

Abdo Badr

Reputable
Mar 10, 2014
128
0
4,710
5
I think they switch automatically, try changing the required program to High performance and your notebook power options to high performance and see if it works, best of luck.
 

Aflow

Reputable
May 4, 2014
2
0
4,510
0


If i Uncheck dual graphics in CCC it runs off the 8650G not the 8750M

Anyone else have a solution? Thanks.
 

Abdo Badr

Reputable
Mar 10, 2014
128
0
4,710
5
I think they switch automatically, try changing the required program to High performance and your notebook power options to high performance and see if it works, best of luck.
 

ASK THE COMMUNITY