[SOLVED] Problems with SSD Write Speeds

NuLLMyndz

Honorable
Nov 2, 2013
18
1
10,515
0
Hello everyone,

Just did a fresh install of Windows 10 Pro on my Samsung 850 EVO 500GB. I noticed some sluggishness so I tested the drive with CrystalDiskMark and Atto. The read speeds are fine, but the write speeds are absolutely atrocious.

The drive is my main drive, trim is activated, indexing is turned off, motherboard bios were updated, and firmware is up to date via Samsung Magician.

Picture of speeds.
View: https://imgur.com/yn2vDga



System:
ASRock 990x Extreme3
AMD FX8350
16GB 1866MHZ HyperX Ram
AMD 390x
Samsung 850EVO 500GB
Corsair 750W Bronze PSU
 
How did you do the fresh install? Did you install any drivers afterwards? If you did you should redo a clean install which means formatting the drive and installing windows clean and tested right after the installation don’t install any other drivers. If it works properly after the clean install that means windows put the right drivers in your system and you shouldn’t mess with it
 

NuLLMyndz

Honorable
Nov 2, 2013
18
1
10,515
0
The windows install was a complete clean install from USB with drive formatted. All drivers were installed by windows. Only things that were changed after install was GPU drivers, indexing on drive turned off, and write caching enabled.


How did you do the fresh install? Did you install any drivers afterwards? If you did you should redo a clean install which means formatting the drive and installing windows clean and tested right after the installation don’t install any other drivers. If it works properly after the clean install that means windows put the right drivers in your system and you shouldn’t mess with it
 

NuLLMyndz

Honorable
Nov 2, 2013
18
1
10,515
0
The USB was created with Windows media creation tool.
I have Samsung Magician installed.
Drive came from another PC and was tested before it came out of that PC with normal speeds 400-500 R/W.

So confusing.
Samsung Magician is saying the drive is fine.
View: https://imgur.com/PFqk0qJ



Write cache should be turned on by default when you do install. Where did you get the windows install media from? Also install Samsung magician and see what it says is wrong with the drive you may have a failing SSD
 

ASK THE COMMUNITY