Question Processor consumes too much power

Jul 31, 2020
29
4
35
0
Hi guys
I have some some question about my cpu, it's behaving weirdly.
Here's a screenshot:


In short, my cpu consumes too much power, and it's way too much from its tdp. I was only opening a couple chrome tabs, one of them is youtube and some translation software and it consumed over 500w. 5 days ago it was around 350w. Even on gaming mode or doing some hard task, it never consumed over 70w. I was just afraid i might damaged my cpu, i know this wasn't supposed to happen.

My system spec:
i5-10400f
G.Skill Ripjaws 2x4GB 2666Mhz
MSI H410-M A-Pro
Zotac GTX 1060 6GB AMP!
ID-COOLING SE-902
550w 80+ Silver PSU
2x 120mm 1k RPM case fans
ADATA 120GB SSD
WD Caviar Blue 500GB 7.2k RPM HDD

Tried changing the PSU, problem still persists

You guys know anything? Help a brother out :(
 
Jul 31, 2020
29
4
35
0
My GPU was idling, around 30w i think. But there's loading cursor when it happened, that's what's been bothering me. I'm afraid there's something running in the background which i'm not aware of.
 

hotaru.hino

Commendable
Sep 1, 2020
1,557
484
1,640
34
The way software tries to measure current may not be the best depending on when it picked up the reading and how it tries to determine power consumption. One time I had one of those monitoring tools tell me a CPU used up 70KW. I'm pretty sure if it really did, I'd have a melted pile of hardware.

If you want a more accurate reading, nothing beats an actual power measuring device like a Kill-A-Watt.
 
Reactions: Master Djoza

Viking2121

Distinguished
Sometimes software readings can be a hit or miss with some motherboards, but as mentioned no way 500+ is right, My 1950x at 4ghz at 1.4v consumes just under 400w according to Open Hardware Monitor, but I also take that with a grain of salt.
 

Karadjgne

Titan
Ambassador
Cpu package power is the whole shebang. Cores, uncore, cache, memory controller, igpu, everything.

So there's absolutely no way that number is right. Or even close. The cores should be the highest sub number, there's nothing on igpu, memory controller is barely there, leaving 300ish watts used by the rest of the uncore? Not likely, especially at a 50ish% load.

And not really all that important either. I'd ignore it or use different software.
 
Reactions: alexbirdie

ASK THE COMMUNITY