Question Program not running after changing graphic card

Oct 3, 2021
2
0
10
0
Hi.

I got a PC which is solely used to run an instrument software, i got 3 of these units in my workplace and recently i got a graphic card problem with one of them, the screen would stay black when the case is turned on, so i tried to swap the graphic card with the other identical PC's that i have and it worked, this pinpointed the problem to the graphic card. Sense the PC are old, i was not able to find any new graphic card for it, so i had to look for something used and even though couldn't find the exact same graphic card.
the original graphic card that came with the system is a "ATI (Sapphire) Radeon X300, 128 MB DDR, VGA/DVI, PCIe x16 ", and the closest one that i found on Ebay is a "Dell UC996 ATI Radeon X300SE 128MB DDR 64-Bit VGA/DVI/HDMI PCIe x16 Video Card".

After getting the replacement graphic card from Ebay, it asked for drivers which i don't understand why because the replacement card uses the same Chipset, should't it be running on the already installed drivers which the old card was running on ?,
i installed the drivers and tried to start the program, but the program would crash on startup and throw an error which mentions stuff about DirectX. if i change the new graphic card with one of the other identical PC's that i have, the program will run with no problems, but with any other card it will crash with the same DirectX error.

Picture of Error attached below.



the company who sold these PC's does not provide any support any longer as these are very old, and in my case it is not worth replacing the whole system just because of a bad graphic card.
I would be very great full for any kind of support.

PC runs of Windows XP


Rgds

Marvin
 
Oct 3, 2021
2
0
10
0
Welcome to the forums, newcomer!

Did you use DDU to uninstall your GPU drivers, prior to populating the used GPU into your build? You will need that specific version linked ion the previous sentence in order to get support on Windows Xp. As for your GPU, it's a detuned version of the X300.
Hi Lutfij

No didn't use DDU before installing the replacement GPU, but i will give that a try since i don't have any other ideas.
any thing else i should look for ?.
 

ASK THE COMMUNITY