Programs sporadically stop responding

dx1

Distinguished
Apr 24, 2007
9
0
18,510
Hello, I started having this problem a few days ago. I have a PC running Windows 7, and every 5-30 seconds, programs I'm running will stop responding for a few seconds.
I've also noticed that the problem is in effect before the operating system is even loaded. My computer sits on the BIOS screen before it loads Windows for far longer than it used to.
I figured it was a problem with the BIOS or some piece of hardware, so I tried resetting the BIOS to the default settings, but that didn't have any affect. I've tried running Memtest and SeaTools to test my memory and hard drives, but no errors were found.
I'm not sure where to go from there. Is there any way I can test the other hardware components or narrow this down further?
Thanks
 

dx1

Distinguished
Apr 24, 2007
9
0
18,510
Thanks for the replies!

Task manager reports about 1.24gb being used out of 4.

I'll start running some virus scans.
Computer is about 4 years old, here are its specs:
(It's a dell XPS 410. Most of the hardware is whatever dell installed, but for two 1gb sticks of ram. If you need me to check on exact brand/model of anything or any other specs, let me know.)
Running Windows 7 Ultimate
Mobo: Dell Phoenix ROM BIOS Plus version 1.10 2.3.1
Processor: Intel Core 2 6600
Memory: 4x1gb DDR2 667MHz
Hard Drives: 2x250gb in raid 1 array
Graphics: ATI Radeon HD 4850
Power Supply: 375w factory installed

Not sure what specs would be helpful, so I think I covered the main stuff. Thanks again for your help