Question PSU causing underperformance

May 13, 2019
30
1
35
0
hello, I have been having a huge problem with underperformance since I have built my PC about 2 months ago. I am getting about 60-70 less frames than my friend with the same components as me except the PSU. It seems like my graphics card never wants to go to high usage. I did switch out the PCIe cable for a new one and saw a small increase in frames. Another weird thing is on some games like BF5 I get the same FPS on all graphic presets, on ultra I get 90 and on low I get maybe 100. just curious to see if the power supply is the problem. thanks in advance for any help.

Specs:
Ryzen 5 2600x
RTX 2070
16GB DDR4-3000MHz RAM
 

AngelTech

Notable
May 18, 2019
1,247
189
990
43
Not really sure if your PSU can cause an issue like that but the CX series isn't really considered very high end so you should probs get a TX series corsair or go with an EVGA PSU
 

TJ Hooker

Illustrious
Herald
Your RAM is only running at 1500 MHz, despite appearing to by a 3200 MHz kit. You need to enable the XMP profile in the BIOS. It may be referred to as DOCP.

After you have done so, please post screenshots of CPU-Z, the Memory and SPR tabs. You can upload them to Imgur and post links here.
 
May 13, 2019
30
1
35
0
Your RAM is only running at 1500 MHz, despite appearing to by a 3200 MHz kit. You need to enable the XMP profile in the BIOS. It may be referred to as DOCP.

After you have done so, please post screenshots of CPU-Z, the Memory and SPR tabs. You can upload them to Imgur and post links here.
It’s 1500 because of DDR so it’s actually 3000, right? It says 3000 in the bios
 

ASK THE COMMUNITY

TRENDING THREADS