• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question PSU fan spins for only a second then stops.

Mar 17, 2020
9
0
10
0
Hello!

One day, I was using my pc like normal and then it just suddenly shut down. Only the motherboard's RGB lighting was on. I unplugged the PC and then replugged it and tried to boot it but only the CPU fan spun for a second and then stopped. The motherboard's RGB light was on though.

I unplugged all the cables and removed the power supply. I have the EVGA SuperNova NEX650G
(650 Watt 80+ Gold) PSU. I removed the motherboard's power cable from the case and connected it to the PSU. I then connected the other end of the cable to the self tester provided. I switched on the PSU and the fan only spun for a second and then stopped completely.

Can someone please tell me what happened to my PSU? Or is this normal behaviour and something else is wrong with my pc?

My Specs:

Ryzen 5 1600X
Corsair 16GB DDR4 3000MHZ Ram (16x1)
Asrock X370 Killer SLI/AC
Evga GeForce GTX 1080
Evga SuperNova NEX650G
 
Hello!

One day, I was using my pc like normal and then it just suddenly shut down. Only the motherboard's RGB lighting was on. I unplugged the PC and then replugged it and tried to boot it but only the CPU fan spun for a second and then stopped. The motherboard's RGB light was on though.

I unplugged all the cables and removed the power supply. I have the EVGA SuperNova NEX650G
(650 Watt 80+ Gold) PSU. I removed the motherboard's power cable from the case and connected it to the PSU. I then connected the other end of the cable to the self tester provided. I switched on the PSU and the fan only spun for a second and then stopped completely.

Can someone please tell me what happened to my PSU? Or is this normal behaviour and something else is wrong with my pc?

My Specs:

Ryzen 5 1600X
Corsair 16GB DDR4 3000MHZ Ram (16x1)
Asrock X370 Killer SLI/AC
Evga GeForce GTX 1080
Evga SuperNova NEX650G
Do you have the eco mode on where the fan doesn't spin under low load?
 

ASK THE COMMUNITY

TRENDING THREADS