PSU keeps turning ON and OFF as soon as I put RAM (any RAM)

salman4u

Honorable
Jun 28, 2012
40
0
10,530
Hello,

I have Asus Z77 Pro 3 Motherboard and I5 3450 processor. I am building my PC today and trying to turn it on. However the PSU keeps turning on and off every 3 seconds or so. But if I remove RAM it stays on continously. This made me thought that there might be an issue with RAM so I tried other RAMs too but I get the same result. Any idea why?

I've installed Cooler Master Hyper Evo 212 cooler. Could it be that pins in CPU socket might have been bent and so it keeps going on and off?
 

OhioLeda

Honorable
Dec 15, 2012
309
0
10,860
Sounds like something is shorted out, loose, broken trace somewhere, a bad wire hiding?
I've found home builds where they used standoffs that are too large which can freak a board out if touching a trace near the hole.

I'd take it apart and make sure it is assembled piece by piece, correct size standoffs, checking the length of each wire and plugs. Sometimes the plugs will push back inside of themselves and not make a tight connection.
Use a magnifying glass and look over the traces for hair line cracks. Something is FUBAR?

When I was a tech at the shop.. It was nice to have extra everything to use and illuminate things with when faced with a stumper like you have.

*Shrug*
 

OhioLeda

Honorable
Dec 15, 2012
309
0
10,860



I thought the same thing. If he is questioning that, then he was unsure of himself putting it together.
It only goes in one way and plops right in. Any force will screw the pins up easily.