Question PSU makes unusual "cracking" noise

lsermokas

Commendable
Sep 30, 2017
2
0
1,510
0
I haven't seen anyone with a similar issue so i'm going to make a post myself. I have an evga 600w white power supply and it seems like this particular power supply tends to make a weird "cracking noise" from time to time (here's what it sounds like
View: https://www.youtube.com/watch?v=mqrwFuW5dCc
) I actually have 2 of these power supplies in different systems and I ran across the same issue on both systems. Can anyone explain why it makes this noise? Should i be worried or just annoyed?
 
post your complete system specs.

can barely hear the noise even with speakers turned all the way up.
but what i do hear doesn't sound like any normal issues that cause PSU noise like fan problems or coil whine.
sounds like a "chirp" that comes at what seems like a regular interval but there was also a quieter sound that seems more like something loose rattling.

if the unit has a regular fan shield that can be removed; try stopping the fan and see if the sound(s) continue.

i would also search around online and on the EVGA forums for anyone mentioning similar issues.
 

lsermokas

Commendable
Sep 30, 2017
2
0
1,510
0
post your complete system specs.

can barely hear the noise even with speakers turned all the way up.
but what i do hear doesn't sound like any normal issues that cause PSU noise like fan problems or coil whine.
sounds like a "chirp" that comes at what seems like a regular interval but there was also a quieter sound that seems more like something loose rattling.

if the unit has a regular fan shield that can be removed; try stopping the fan and see if the sound(s) continue.

i would also search around online and on the EVGA forums for anyone mentioning similar issues.
gtx 1660 super, ryzen 5 3600, 1 tb hd 1 200gb ssd motherboard asus rog strix b450-f, 75hz 1080p monitor
the power supply still makes the noise even when idle on power saver so I wouldn't think that the power supply is under any stress
 
I haven't seen anyone with a similar issue so i'm going to make a post myself. I have an evga 600w white power supply and it seems like this particular power supply tends to make a weird "cracking noise" from time to time (here's what it sounds like

) I actually have 2 of these power supplies in different systems and I ran across the same issue on both systems. Can anyone explain why it makes this noise? Should i be worried or just annoyed?
Weird. It's like a "chirp" or a "scrape" noise to me.
 

ASK THE COMMUNITY

TRENDING THREADS