• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Psu problem maybe?

Jul 7, 2020
7
0
10
0
I’m getting into pc building and thought it would be good to get started with a old prebuilt. I ordered and dell vostro 260 and everything worked fine with its psu. I wanted to upgrade my psu so I could add a gpu to it. I bought a rosewill 1000w psu that came as a deal with the pc. When I took the old psu out and added the new one everything seemed fine. Then I stumbled over a problem. With the new psu the pc would turn on run for a few seconds then turn off and reboot. The psu led light were still in showing that it was receiving power but kept cycling on and off when turning on my pc. Is the a psu problem and do I need to get a new one?
 
Jul 7, 2020
7
0
10
0
I got a new psu for my computer. Old one works and boots the computer, but the new one make me my computer do a boot loop. It cuts on stays on for few seconds and then shuts off and repeats the process is my battery bad?
 
Jul 7, 2020
7
0
10
0
full system spec? include make and model of the psu

does the dell have standard psu connection on the motherboard?
The dell works fine with the standard psu and yes it has the standard 20+4 pin connection as far as the system specs all of them are what comes with a dell vostro 260


Processor: i3-2120 @ 3.3 ghz
Ram: 8 gb
Storage: 250 gb HDD
Integrated graphics
psu is the standard psu that comes with the computer and the new one I bought is an rosewill 1000w psu 80 br
 

ASK THE COMMUNITY

TRENDING THREADS