Question PSU problems

Apr 26, 2022
25
0
30
0
Hello.
Today I was playing video game and after I finished playing I got a blue screen.
I started my PC again, but after 1 second power just cut off. So, basically the PC starts for a second and then loses power.
I tried cleaning up the dust, but it didn't help.
 

Lutfij

Titan
Moderator
When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:

Include the age of the PSU apart from it's make and model.
 
Apr 26, 2022
25
0
30
0
I'm not sure what the age is, my PSU is strike-x PSU 800W.
My CPU: i5-4690k
My RAM: 6GB DDR3-1300
My Mainboard: B85 i think maybe I'm wrong
 
Apr 26, 2022
25
0
30
0
I've got a big update!!!

After changing my PSU, same problem.
PC starts and cuts off.
Could it be a Motherboard problem? I'm not sure..


EDIT:
When I removed my CPU, PC started normally.
 
Last edited:

Vic 40

Titan
Ambassador
Did you also test with just one stick of ram? 6gb means a mix of two or three sticks which not always might work well.

If it is the cpu is that too bad, but those for that socket should be cheap enough if you want to continue with that pc.
 
Apr 26, 2022
25
0
30
0
Did you also test with just one stick of ram? 6gb means a mix of two or three sticks which not always might work well.

If it is the cpu is that too bad, but those for that socket should be cheap enough if you want to continue with that pc.
Hi.

I use 6GB on single channel, because I got another problem on this mainboard.

My B channel just doesn't work, and when I put my 4x2 in all 4 slots, PC turns on, but I get a black screen. All those sticks are operative(I tested every single stick) and I don't know where the problem is.

I wanted to give it just 4GB because of 2x2 but I think it would be too less, because my graphics card died a couple of days ago. and I have to share memory to my Integrated GPU, so now, I use one stick 4gb and one 2gb in channel A.

Any solution? :(
 

Vic 40

Titan
Ambassador
Since only one channel works might it be good to reinstall the cpu and make sure the cooler is snug on all sides, also check for bent pins in the socket, why i want you to get it (the cpu) out in the first place.
 
Apr 26, 2022
25
0
30
0
Since only one channel works might it be good to reinstall the cpu and make sure the cooler is snug on all sides, also check for bent pins in the socket, why i want you to get it (the cpu) out in the first place.
I did it 10 times yet, and still no work. Pins are looking okay, but I don't know. The CPU made power problems too, so could it be the CPU? (When I started my PC, it just kept cutting off until I reinstalled my CPU, now PC works but RAM is a problem)

Really weird problem for me. :/

I got an old BIOS. Should I update it?

Because my case is rly bad and doesn't have holes to screw cooler up on that side, my cooler is not screwed up so as not to damage the motherboard or something like that. But it still cools the CPU fine.
 

ASK THE COMMUNITY