PSU seems to have something blocking the entrance of my 24 pin atx cable?

Kidscamp11

Reputable
Feb 6, 2015
40
0
4,530
0
My first build. I already feel like I'm doing bad. I go to plug in the motherboard atx pin into the PSU and there seems to be a little white thing blocking the entrance of the bottom pin? I'm not sure how to include a picture from a mobile device. If anyone can help please do.
 

jgustin7b

Commendable
Nov 17, 2017
1,216
0
1,660
195
Is the white thing on the plug itself or the mobo? I believe it’s a cap you can just take off, but pics may help. I find it easier to just download imgur app: make an account, post the pic (be sure it’s public), and use the share feature to copy the link here.
 

Kidscamp11

Reputable
Feb 6, 2015
40
0
4,530
0


No it's literally inside of the psu connector.

Idk if you can see that but it's sort of blocking the bottom connector.
 

Kidscamp11

Reputable
Feb 6, 2015
40
0
4,530
0

I'm sorry I'm trying to create an imgur but it wont activate my account to post the image so I'm trying to figure this all out.
 

Kidscamp11

Reputable
Feb 6, 2015
40
0
4,530
0


Is there a phone number or something I can text it to? It's not working and I'm becoming very stressed out.
 

jgustin7b

Commendable
Nov 17, 2017
1,216
0
1,660
195
No problem on the imgur thing. There should be alt.’s somewhere. As for the number, not happening. Would lead to a ban of sorts knowing the rules of conduct here. Although my email is my username @gmail.com. That I practically gave away to everyone anyways.
 

Similar threads


TRENDING THREADS