PSU thermaltake not powering upmy computer

lachihoog

Prominent
Nov 4, 2017
12
0
510
0
Hello today I bought a new PSU
Thermal take smart se 530 Watts replaced my old standard PSU hkc 430 w max load because it's not enough for my rx570 Gpu
So plugged everything in presses the start button it didn't turn on I have an Asus p7h55 checked this website here
http://www.pc-specs.com/mobo/Asus/Asus_P7H55-V/785/Compatible_PSUs
says the PSU I bought is compatible with the p7h55-v which is the Same as p7h55 I think
After so many failed attempts to start the computer I decided to try my old crap psu and it did turn the computer on I don't understand what's happening why is my old psu turning the computer on while the recently bought psu which has more power doesn't start it off can you please help me ?
 

lachihoog

Prominent
Nov 4, 2017
12
0
510
0
MERGED QUESTION
Question from lachihoog : "Power supply thermaltake se530 not turning on my computer"

Hello today I bought a new PSU
Thermal take smart se 530 Watts replaced my old standard PSU hkc 430 w max load because it's not enough for my rx570 Gpu
So plugged everything in presses the start button it didn't turn on I have an Asus p7h55 checked this website here
http://www.pc-specs.com/mobo/Asus/Asus_P7H55-V/785/Compatible_PSUs
says the PSU I bought is compatible with the p7h55-v which is the Same as p7h55 I think
After so many failed attempts to start the computer I decided to try my old crap psu and it did turn the computer on I don't understand what's happening why is my old psu turning the computer on while the recently bought psu which has more power doesn't start it off can you please help me ?
 

ASK THE COMMUNITY

TRENDING THREADS